summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Gysel <me@bearsh.org>2020-02-15 23:52:45 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-07 13:13:46 +0200
commite2b7a6e1f367d473880f5a5466f0712eebfe4e53 (patch)
tree46201fac69942f72bc980f6f80666aeca0900fa9 /dev-embedded
parentdev-util/cppunit: drop 1.14.0 (diff)
downloadgentoo-e2b7a6e1f367d473880f5a5466f0712eebfe4e53.tar.gz
gentoo-e2b7a6e1f367d473880f5a5466f0712eebfe4e53.tar.bz2
gentoo-e2b7a6e1f367d473880f5a5466f0712eebfe4e53.zip
dev-embedded/ponyprog: 3.1.2 version bump
- switch to eapi7 and cmake.eclass - use forked qhexedit2 but as internal copy - add dep on libusb and libftdi Bug: https://bugs.gentoo.org/696626 Signed-off-by: Martin Gysel <me@bearsh.org> Closes: https://github.com/gentoo/gentoo/pull/19870 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/ponyprog/Manifest2
-rw-r--r--dev-embedded/ponyprog/files/ponyprog-3.1.1-fix-build-system.patch17
-rw-r--r--dev-embedded/ponyprog/ponyprog-3.1.2.ebuild52
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-embedded/ponyprog/Manifest b/dev-embedded/ponyprog/Manifest
index 8982475ff20c..7483bee8e97d 100644
--- a/dev-embedded/ponyprog/Manifest
+++ b/dev-embedded/ponyprog/Manifest
@@ -1 +1,3 @@
DIST ponyprog-3.0.0.tar.gz 933166 BLAKE2B 46eb0a720c91ed187ef06907b28d8b84ecbe4c62a92cabf2b9ff58c553e3f8afc949e523d6b97af0cbf168c545b71e0395e02e5c182714a76bbacce645a1d890 SHA512 a1779b28e03f824fb242d6eb063f0e038af26602c26d5392884f69cbbccac8a934660dffa9bec7489aeb2656e35f21e2b097fc6fe011f278046894e180023881
+DIST ponyprog-3.1.2.tar.gz 1364636 BLAKE2B a913903278791d937266da50fcd5b5bda892dcc316011117816e37fc4ef03becce893b597fb34f2a6ef05b5692bb375e4ba10b04c079a63eb735aa0ddadb5ab9 SHA512 697c6fdc775629086a1c01ad94f291fda550a9ad6065e5fdff9db9fb035b8270ed9058894db7ca17d0daf2a26cc5e431415c160d61f65214677eae2109d87603
+DIST qhexedit2-ponyprog-3.1.2.tar.gz 342443 BLAKE2B d9f31d1590dd1636fdc74297a95036c9900dc0b4e15c656c82dcfa04b7a1629931ec2622a8e6a923a784a4d7f46f0b084b0126263ae7b00ad79ad3914e35fef4 SHA512 861b1255aef0dc6f7d3459a98b26df58aed676156c12c72b96c8beef33dee0a2528fa87438c7163c839d6e617d531acc40f92f07080ac395fb93d9cc0a045fb1
diff --git a/dev-embedded/ponyprog/files/ponyprog-3.1.1-fix-build-system.patch b/dev-embedded/ponyprog/files/ponyprog-3.1.1-fix-build-system.patch
new file mode 100644
index 000000000000..9f4e44d69267
--- /dev/null
+++ b/dev-embedded/ponyprog/files/ponyprog-3.1.1-fix-build-system.patch
@@ -0,0 +1,17 @@
+--- a/CMakeLists.txt.old 2020-02-15 13:35:28.308010048 +0100
++++ b/CMakeLists.txt 2020-02-15 13:37:06.726655159 +0100
+@@ -42,14 +42,6 @@
+ OPTION (USE_PROFILER "Include in binary file profiling information" OFF)
+
+
+-IF(${USE_DEBUGGER})
+- SET(CMAKE_BUILD_TYPE Debug)
+- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS_DEBUG} -Wall")
+-ELSE()
+- SET(CMAKE_BUILD_TYPE Release)
+- SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS_RELEASE} -Wall")
+-ENDIF()
+-
+ MESSAGE(STATUS "CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS}")
+
+ INCLUDE(CheckIncludeFile)
diff --git a/dev-embedded/ponyprog/ponyprog-3.1.2.ebuild b/dev-embedded/ponyprog/ponyprog-3.1.2.ebuild
new file mode 100644
index 000000000000..e70fbc5abc00
--- /dev/null
+++ b/dev-embedded/ponyprog/ponyprog-3.1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+QHEXEDIT2_HASH="64f50820118c450ab49ae63bfd9b143eb1971058"
+
+DESCRIPTION="EEPROM and microcontroller programmer/flasher"
+HOMEPAGE="https://github.com/lancos/ponyprog/"
+SRC_URI="https://github.com/lancos/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/lancos/qhexedit2/archive/${QHEXEDIT2_HASH}.tar.gz -> qhexedit2-${P}.tar.gz
+"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+# blocker on libftdi-1.5-r2: see #775116
+RDEPEND="dev-embedded/libftdi:1[cxx]
+ !=dev-embedded/libftdi-1.5-r2
+ virtual/libusb:1
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtprintsupport:5"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-fix-build-system.patch
+)
+
+src_unpack() {
+ default
+ mv qhexedit2-*/src ${P}/qhexedit2/ || die "moving qhexedit2 failed"
+}
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}" )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ elog "To use the COM port in user mode (not as root), you need to"
+ elog "be in the 'uucp' group."
+ elog
+ elog "To use the LPT port in user mode (not as root) you need a kernel with"
+ elog "ppdev, parport and parport_pc compiled in or as modules. You need the"
+ elog "rights to write to /dev/parport? devices."
+}