summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-04-01 11:46:47 +0200
committerHanno Böck <hanno@gentoo.org>2020-04-01 11:46:47 +0200
commit1c89c3d176872bcca16435fb228da0ef14a95317 (patch)
tree61e95f94c206c422a9461cec0df69277e032fece /dev-erlang/esip/esip-1.0.32.ebuild
parentdev-erlang/stun: Version bump (diff)
downloadgentoo-1c89c3d176872bcca16435fb228da0ef14a95317.tar.gz
gentoo-1c89c3d176872bcca16435fb228da0ef14a95317.tar.bz2
gentoo-1c89c3d176872bcca16435fb228da0ef14a95317.zip
dev-erlang/esip: Version bump
Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-2.3.96, Repoman-2.3.22
Diffstat (limited to 'dev-erlang/esip/esip-1.0.32.ebuild')
-rw-r--r--dev-erlang/esip/esip-1.0.32.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-erlang/esip/esip-1.0.32.ebuild b/dev-erlang/esip/esip-1.0.32.ebuild
new file mode 100644
index 000000000000..414375ad7685
--- /dev/null
+++ b/dev-erlang/esip/esip-1.0.32.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="ProcessOne SIP server component"
+HOMEPAGE="https://github.com/processone/esip"
+SRC_URI="https://github.com/processone/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/erlang-17.1
+ >=dev-erlang/fast_tls-1.1.4
+ >=dev-erlang/stun-1.0.31
+ >=dev-erlang/p1_utils-1.0.18"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ rebar_src_prepare
+ rebar_fix_include_path stun
+
+ # ebin contains lonely .gitignore file asking for removal.
+ rm -r "${S}/ebin" || die
+}