summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:24 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:32 +0100
commit80cd14b026b0f7b26028c5e748c03ada0789939e (patch)
treeb50a22f4fcb1f8939201654138855ea0e5ef5acb /dev-haskell/cairo
parentdev-haskell/gtk2hs-buildtools: new package, add 0.13.10.0 (diff)
downloadgentoo-80cd14b026b0f7b26028c5e748c03ada0789939e.tar.gz
gentoo-80cd14b026b0f7b26028c5e748c03ada0789939e.tar.bz2
gentoo-80cd14b026b0f7b26028c5e748c03ada0789939e.zip
dev-haskell/cairo: new package, add 0.13.10.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/cairo')
-rw-r--r--dev-haskell/cairo/Manifest1
-rw-r--r--dev-haskell/cairo/cairo-0.13.10.0.ebuild39
-rw-r--r--dev-haskell/cairo/metadata.xml15
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/cairo/Manifest b/dev-haskell/cairo/Manifest
new file mode 100644
index 000000000000..14b05702e273
--- /dev/null
+++ b/dev-haskell/cairo/Manifest
@@ -0,0 +1 @@
+DIST cairo-0.13.10.0.tar.gz 53346 BLAKE2B dd6d4d6b4fcfe0212823bbfc01d1edef7cb0a6e776c74d85419c91d6f48757ce1d9f36855c54fa88a4eb448de3c70a9b22bec99647e5e49988770249f14a950a SHA512 86465f37999144a8330b2921eb7233a6a1e5258ac9debe4c70c515ccc183ed6cc04dca3a3ca91978e0d3d2871e4a601253e147fd5b3e76f4839a37cbf9deabfa
diff --git a/dev-haskell/cairo/cairo-0.13.10.0.ebuild b/dev-haskell/cairo/cairo-0.13.10.0.ebuild
new file mode 100644
index 000000000000..84caaa8cda97
--- /dev/null
+++ b/dev-haskell/cairo/cairo-0.13.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+#hackport: flags: +cairo_pdf,+cairo_ps,cairo_svg:svg
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Cairo library"
+HOMEPAGE="https://projects.haskell.org/gtk2hs/"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+svg"
+
+RDEPEND=">=dev-haskell/text-1.0.0.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ >=dev-haskell/utf8-string-0.2:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ x11-libs/cairo
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0 <dev-haskell/cabal-3.11
+"
+BDEPEND=">=dev-haskell/gtk2hs-buildtools-0.13.2.0 <dev-haskell/gtk2hs-buildtools-0.14
+ virtual/pkgconfig
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=cairo_pdf \
+ --flag=cairo_ps \
+ $(cabal_flag svg cairo_svg)
+}
+
+GHC_BOOTSTRAP_PACKAGES=( gtk2hs-buildtools )
diff --git a/dev-haskell/cairo/metadata.xml b/dev-haskell/cairo/metadata.xml
new file mode 100644
index 000000000000..3778b9cd1ba8
--- /dev/null
+++ b/dev-haskell/cairo/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="svg">Build the Scalable Vector Graphics (SVG) backend of Cairo.</flag>
+ </use>
+ <upstream>
+ <remote-id type="hackage">cairo</remote-id>
+ <remote-id type="github">gtk2hs/gtk2hs</remote-id>
+ </upstream>
+</pkgmetadata>