summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/cryptocipher
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/cryptocipher')
-rw-r--r--dev-haskell/cryptocipher/Manifest2
-rw-r--r--dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild37
-rw-r--r--dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild31
-rw-r--r--dev-haskell/cryptocipher/metadata.xml11
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-haskell/cryptocipher/Manifest b/dev-haskell/cryptocipher/Manifest
new file mode 100644
index 000000000000..c9122d1adffa
--- /dev/null
+++ b/dev-haskell/cryptocipher/Manifest
@@ -0,0 +1,2 @@
+DIST cryptocipher-0.5.2.tar.gz 22384 SHA256 f913b1274fe616b6c5232bada2f39291ffefa85d6f77301f5c3fc40d051fcd39 SHA512 f9e76805b27b7002f5393893d9cac30998c82f3d5759be48a25907c95ab0d8250c2e54dea252c1881bca5117fb2fe3fcc59b304265b6db286e1f1a2d733a631d WHIRLPOOL 52b88a0c65aa5debcffa808947b0cabffe5540afcd68abcc6be1989764c0a9411dbd852b25a8442298d583cf396b6805f8e35f3d6e8ff00b7ce2a95025a46715
+DIST cryptocipher-0.6.2.tar.gz 2027 SHA256 34b9e62dee36c4019dd0c0e86576295d0bd1bb573eeb24686ec635a09550e346 SHA512 d63984d26e355ff613a4176c11634f1012f8b9ec43180ffed236f37aa7a1b1dafee1871799eec53774544518c886c27ae19bb0b058288da6bd8f2b45eaa5e5ab WHIRLPOOL cdb8714c0ef67c412a95c38aee740b552760faf89a5d4a0d3a9bcc9653229b00119a5d091bebea2e6713d8c4404b8895dea9db26c46eee30293defe4cc99ab9d
diff --git a/dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild b/dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild
new file mode 100644
index 000000000000..6aff4c227778
--- /dev/null
+++ b/dev-haskell/cryptocipher/cryptocipher-0.5.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Symmetrical block and stream ciphers"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ dev-haskell/cipher-aes:=[profile?]
+ dev-haskell/cipher-rc4:=[profile?]
+ =dev-haskell/cpu-0.1*:=[profile?]
+ >=dev-haskell/crypto-api-0.5:=[profile?]
+ dev-haskell/primitive:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/cryptohash
+ dev-haskell/entropy
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9
+ )"
diff --git a/dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild b/dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild
new file mode 100644
index 000000000000..c48bc0911174
--- /dev/null
+++ b/dev-haskell/cryptocipher/cryptocipher-0.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Symmetrical block and stream ciphers"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cipher-aes-0.2.3:=[profile?] <dev-haskell/cipher-aes-0.3:=[profile?]
+ >=dev-haskell/cipher-blowfish-0.0:=[profile?] <dev-haskell/cipher-blowfish-0.1:=[profile?]
+ >=dev-haskell/cipher-camellia-0.0:=[profile?] <dev-haskell/cipher-camellia-0.1:=[profile?]
+ >=dev-haskell/cipher-des-0.0:=[profile?] <dev-haskell/cipher-des-0.1:=[profile?]
+ >=dev-haskell/cipher-rc4-0.1.3:=[profile?] <dev-haskell/cipher-rc4-0.2:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.8:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
diff --git a/dev-haskell/cryptocipher/metadata.xml b/dev-haskell/cryptocipher/metadata.xml
new file mode 100644
index 000000000000..ab6465e4bcba
--- /dev/null
+++ b/dev-haskell/cryptocipher/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Symmetrical Block, Stream and PubKey Ciphers
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-cipher</remote-id>
+ </upstream>
+</pkgmetadata>