summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:06:54 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:25 +0100
commitadf9062d75b475b3b6863a98de528ffa6803b900 (patch)
tree20079bd5aaabdc6f92e8c503768b74a8319e82c3 /dev-haskell/cryptohash-sha1
parentdev-haskell/cryptohash-md5: Migrate to CABAL_CHDEPS (diff)
downloadgentoo-adf9062d75b475b3b6863a98de528ffa6803b900.tar.gz
gentoo-adf9062d75b475b3b6863a98de528ffa6803b900.tar.bz2
gentoo-adf9062d75b475b3b6863a98de528ffa6803b900.zip
dev-haskell/cryptohash-sha1: add 0.11.101.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/cryptohash-sha1')
-rw-r--r--dev-haskell/cryptohash-sha1/Manifest2
-rw-r--r--dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.101.0.ebuild29
-rw-r--r--dev-haskell/cryptohash-sha1/metadata.xml20
3 files changed, 35 insertions, 16 deletions
diff --git a/dev-haskell/cryptohash-sha1/Manifest b/dev-haskell/cryptohash-sha1/Manifest
index 763430616331..ec9b31b24686 100644
--- a/dev-haskell/cryptohash-sha1/Manifest
+++ b/dev-haskell/cryptohash-sha1/Manifest
@@ -1 +1,3 @@
DIST cryptohash-sha1-0.11.100.1.tar.gz 10198 BLAKE2B 5d9835feeb43a80c83de0e390d59efc908fd538ed4146ace4eb0cd67392503cf414a2324968e8249f2b506978348caa6e92c70e82c52eaa7ac14e3956388f05e SHA512 e3528c70501ffaf4649adc0fe120a0b333329761fa66505083269afa67828c16695fd91567035adef0b77915df47a6bcc99d2d90f0ecb26eda583829261cb1bc
+DIST cryptohash-sha1-0.11.101.0-rev2.cabal 3094 BLAKE2B fc048a5eaefca1df4b1748f46f48f69e7571f90fdfdb3524b7556a8b6a9b3f7b58d363209ec20d9f4892b1b3e69dc1394287e7e70e7009f06dd75bc02e267910 SHA512 1dbf660ca81c2d8633dd6255602fa6b5f2999f55400bd75391be0049ca8bcf221d14b5d294999427ed193aa0514d68e05509b85fc5a2fe9c8be574b0a0542f9a
+DIST cryptohash-sha1-0.11.101.0.tar.gz 11563 BLAKE2B 4da99b2b4943e3909d3af24f62fb0ecf4c87370075f280a7e9ea44956cd58df9f49076a0d90b60bec9a7dcb3d24df032f6b5ef07644a4b63bdf1099458996163 SHA512 4384fc2f63750400561b5dbea0a343510306d755131121346d6a52cb9420cb12fc7d20247f044beb0ea55ae254ce666edc982d76e999c0762894f405e9b6441e
diff --git a/dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.101.0.ebuild b/dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.101.0.ebuild
new file mode 100644
index 000000000000..5c3d3f9e7023
--- /dev/null
+++ b/dev-haskell/cryptohash-sha1/cryptohash-sha1-0.11.101.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=2
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Fast, pure and practical SHA-1 implementation"
+HOMEPAGE="https://github.com/haskell-hvr/cryptohash-sha1"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( >=dev-haskell/base16-bytestring-1.0.1.0 <dev-haskell/base16-bytestring-1.1
+ >=dev-haskell/sha-1.6.4 <dev-haskell/sha-1.7
+ >=dev-haskell/tasty-1.4 <dev-haskell/tasty-1.5
+ >=dev-haskell/tasty-hunit-0.10 <dev-haskell/tasty-hunit-0.11
+ >=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11 )
+"
diff --git a/dev-haskell/cryptohash-sha1/metadata.xml b/dev-haskell/cryptohash-sha1/metadata.xml
index 9f3f3141af03..114f360e78d9 100644
--- a/dev-haskell/cryptohash-sha1/metadata.xml
+++ b/dev-haskell/cryptohash-sha1/metadata.xml
@@ -5,20 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- A practical incremental and one-pass, pure API to the
- &lt;https://en.wikipedia.org/wiki/SHA-1 SHA-1 hash algorithm&gt;
- (including &lt;https://en.wikipedia.org/wiki/HMAC HMAC&gt; support)
- with performance close to the fastest implementations available in other languages.
-
- The implementation is made in C with a haskell FFI wrapper that hides the C implementation.
-
- NOTE: This package has been forked off @cryptohash-0.11.7@ because the @cryptohash@ package has been
- deprecated and so this package continues to satisfy the need for a lightweight package
- providing the SHA1 hash algorithm without any dependencies on packages other than
- @base@ and @bytestring@.
-
- Consequently, this package can be used as a drop-in replacement for @cryptohash@'s
- "Crypto.Hash.SHA1" module, though with a clearly smaller footprint.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">cryptohash-sha1</remote-id>
+ <remote-id type="github">haskell-hvr/cryptohash-sha1</remote-id>
+ </upstream>
</pkgmetadata>