summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:26 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:34 +0100
commit2de3efe457301237c91ec19ea961bf228bc06b2a (patch)
tree97ddd1da3f6fac4f69b5de7d58e07eb0640445a0 /dev-haskell/foldl
parentdev-haskell/fingertree: add 0.1.5.0 (diff)
downloadgentoo-2de3efe457301237c91ec19ea961bf228bc06b2a.tar.gz
gentoo-2de3efe457301237c91ec19ea961bf228bc06b2a.tar.bz2
gentoo-2de3efe457301237c91ec19ea961bf228bc06b2a.zip
dev-haskell/foldl: add 1.4.15
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/foldl')
-rw-r--r--dev-haskell/foldl/Manifest1
-rw-r--r--dev-haskell/foldl/foldl-1.4.15.ebuild39
-rw-r--r--dev-haskell/foldl/metadata.xml10
3 files changed, 44 insertions, 6 deletions
diff --git a/dev-haskell/foldl/Manifest b/dev-haskell/foldl/Manifest
index 37bde468299e..342d69e7b402 100644
--- a/dev-haskell/foldl/Manifest
+++ b/dev-haskell/foldl/Manifest
@@ -1,2 +1,3 @@
DIST foldl-1.4.12-rev5.cabal 2682 BLAKE2B 616f3b1d69892cdf30039db5c82842d858b58d227f96e301b594e51b2052c7f423264b11a82c82669cc736b337dca901e242177064b0bf2b4cf128da619935b2 SHA512 394fe8ba15a59a270bc70deed3438a2d1e5193bfa3ec266dbdc3bac48e0b32279cbaab6dfb550cc551f48ce466a9bc553d1ea3748f90836f95f158818d267bd5
DIST foldl-1.4.12.tar.gz 23210 BLAKE2B bbdd9a0b74d5b27b4b8800090a1b2dc717d023d860af8f26846a86866756211b30c755f6a1c3e604d6d1db91e5afa35ee943e014672c0a6e65712e0fbcfd29d0 SHA512 6b345b59c52039e914ea703ab88a08a8bba0a18bea91fcf4cf379ce678e5a97044f563c7b285cb656a764068756b4fae8321308e86813f86d04c462e9889e6e0
+DIST foldl-1.4.15.tar.gz 24449 BLAKE2B c8656bc7231e110dccf44e465acf33f9a61ad91020c8cb0b27debacde2ed4ba8c0de98d17c47db3218de4b56f3f026a8da74d092caca0b9fa66db4998a3017d4 SHA512 a0fb401313d8cb1911cc64e93cee7446a1785fac531f77b5f56a1165617c8adca8470be8a60555a07b48156924c657f4eee3094ad7a043fc383b459fa0006328
diff --git a/dev-haskell/foldl/foldl-1.4.15.ebuild b/dev-haskell/foldl/foldl-1.4.15.ebuild
new file mode 100644
index 000000000000..bc6602decc62
--- /dev/null
+++ b/dev-haskell/foldl/foldl-1.4.15.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Composable, streaming, and efficient left folds"
+HOMEPAGE="https://hackage.haskell.org/package/foldl"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+PATCHES=( "${FILESDIR}/${PN}-1.4.12-cabal-doctest.patch" )
+
+GHC_BOOTSTRAP_PACKAGES=(
+ cabal-doctest
+)
+
+RDEPEND=">=dev-haskell/comonad-4.0:=[profile?] <dev-haskell/comonad-6:=[profile?]
+ <dev-haskell/contravariant-1.6:=[profile?]
+ <dev-haskell/hashable-1.5:=[profile?]
+ <dev-haskell/primitive-0.9:=[profile?]
+ >=dev-haskell/profunctors-4.3.2:=[profile?] <dev-haskell/profunctors-5.7:=[profile?]
+ >=dev-haskell/random-1.2:=[profile?] <dev-haskell/random-1.3:=[profile?]
+ >=dev-haskell/semigroupoids-1.0:=[profile?] <dev-haskell/semigroupoids-6.1:=[profile?]
+ >=dev-haskell/text-0.11.2.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+ <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?] <dev-haskell/vector-0.14:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/doctest-0.16 )
+"
diff --git a/dev-haskell/foldl/metadata.xml b/dev-haskell/foldl/metadata.xml
index f258fcc54de0..1582dd67b890 100644
--- a/dev-haskell/foldl/metadata.xml
+++ b/dev-haskell/foldl/metadata.xml
@@ -5,10 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- This library provides strict left folds that stream in constant
- memory, and you can combine folds using @Applicative@ style to derive new
- folds. Derived folds still traverse the container just once and are often as
- efficient as hand-written folds.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">foldl</remote-id>
+ <remote-id type="github">Gabriella439/Haskell-Foldl-Library</remote-id>
+ </upstream>
</pkgmetadata>