summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:37:53 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:57:10 +0000
commit3538d4113e5258a931cb8c2e0a23302c759839b2 (patch)
treef3dd2a15ec78c88174f5f9160377104978706bd7 /dev-haskell/http-reverse-proxy/http-reverse-proxy-0.4.3.2.ebuild
parentdev-haskell/monad-logger: bump up to 0.3.20.1 (diff)
downloadgentoo-3538d4113e5258a931cb8c2e0a23302c759839b2.tar.gz
gentoo-3538d4113e5258a931cb8c2e0a23302c759839b2.tar.bz2
gentoo-3538d4113e5258a931cb8c2e0a23302c759839b2.zip
dev-haskell/http-reverse-proxy: bump up to 0.4.3.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/http-reverse-proxy/http-reverse-proxy-0.4.3.2.ebuild')
-rw-r--r--dev-haskell/http-reverse-proxy/http-reverse-proxy-0.4.3.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.4.3.2.ebuild b/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.4.3.2.ebuild
new file mode 100644
index 000000000000..3fcbf8f5a96d
--- /dev/null
+++ b/dev-haskell/http-reverse-proxy/http-reverse-proxy-0.4.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Reverse proxy HTTP requests, either over raw sockets or with WAI"
+HOMEPAGE="https://github.com/fpco/http-reverse-proxy"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/async:=[profile?]
+ >=dev-haskell/blaze-builder-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-0.4:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?]
+ dev-haskell/conduit-extra:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/http-client-0.3:=[profile?]
+ >=dev-haskell/http-types-0.6:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ dev-haskell/streaming-commons:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/wai-3.0:=[profile?]
+ dev-haskell/wai-logger:=[profile?]
+ >=dev-haskell/word8-0.0:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/http-conduit
+ >=dev-haskell/warp-2.1 )
+"