summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 20:17:44 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:15:29 +0000
commit340b9675926c93ecbe3f2546e97a9954af7ca537 (patch)
tree95424b78036bb7c6177efa0e40367313514d72a8 /dev-haskell/nats
parentdev-haskell/nanospec: keyword 0.2.2 for ~ppc64 (diff)
downloadgentoo-340b9675926c93ecbe3f2546e97a9954af7ca537.tar.gz
gentoo-340b9675926c93ecbe3f2546e97a9954af7ca537.tar.bz2
gentoo-340b9675926c93ecbe3f2546e97a9954af7ca537.zip
dev-haskell/nats: revbump 1.1.2-r1
https://github.com/gentoo-haskell/gentoo-haskell/commit/849679e70a2de545e304f3677342c2d3d2f28cc0 Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/nats')
-rw-r--r--dev-haskell/nats/Manifest1
-rw-r--r--dev-haskell/nats/nats-1.1.2-r1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-haskell/nats/Manifest b/dev-haskell/nats/Manifest
index fa84eee00c07..a8cf5a997b14 100644
--- a/dev-haskell/nats/Manifest
+++ b/dev-haskell/nats/Manifest
@@ -1 +1,2 @@
+DIST nats-1.1.2-r1.cabal 2749 BLAKE2B b0b7406ce0362cfea14dd8cc492b9d0a5a1e34ae4cf5c4aba78d3cd7052a24a3be1c742287d85e6f9699fecbeee491a0eadcdf1994e92ce86e559c6965774cc2 SHA512 0702e4a69cbc368de33993ab49ab5aa458202df538606b73dd9291a6cf61f82ab44e4b12e3e82d2690ba151fe8b1c65e8791ac0f45a24a7f2534abdebd2e87cb
DIST nats-1.1.2.tar.gz 7776 BLAKE2B ae2012e1e8a433c3802b7470f95a7e4b391f9c7ee50f41b94d2ee9d20b630820e550efa76fb5d64926942e87e761db0702ae4310573d0bca38f52fa419a93390 SHA512 596f11e98fe57893279ddd1f5af11a12e747e0d5e87000c7e20d0f5c2da0f0be9a6b8d19c8d5759716a7fb9a3e77d0e999380af3d5a350fe32a5492dc6077450
diff --git a/dev-haskell/nats/nats-1.1.2-r1.ebuild b/dev-haskell/nats/nats-1.1.2-r1.ebuild
new file mode 100644
index 000000000000..7fc284ca23e7
--- /dev/null
+++ b/dev-haskell/nats/nats-1.1.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile"
+# break circular dependencies:
+# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Natural numbers"
+HOMEPAGE="https://github.com/ekmett/nats/"
+SRC_URI="
+ https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/3.cabal -> ${PF}.cabal"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+binary +hashable +template-haskell"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+ hashable? ( >=dev-haskell/hashable-1.1.2.0:=[profile?] )
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag binary binary) \
+ $(cabal_flag hashable hashable) \
+ $(cabal_flag template-haskell template-haskell)
+}