summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:05:34 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:07 +0100
commit6bb0bea1021ec4e0de3b22a5a22ea0ea8de01119 (patch)
tree6b9e3a28a4640d3fd3330d13002debdd3760f7ec /dev-haskell/pandoc-lua-marshal
parentdev-haskell/lpeg: add 1.0.4 (diff)
downloadgentoo-6bb0bea1021ec4e0de3b22a5a22ea0ea8de01119.tar.gz
gentoo-6bb0bea1021ec4e0de3b22a5a22ea0ea8de01119.tar.bz2
gentoo-6bb0bea1021ec4e0de3b22a5a22ea0ea8de01119.zip
dev-haskell/pandoc-lua-marshal: add 0.2.2
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/pandoc-lua-marshal')
-rw-r--r--dev-haskell/pandoc-lua-marshal/Manifest1
-rw-r--r--dev-haskell/pandoc-lua-marshal/metadata.xml4
-rw-r--r--dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.2.2.ebuild35
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/pandoc-lua-marshal/Manifest b/dev-haskell/pandoc-lua-marshal/Manifest
index cad348d9abaa..c01529711831 100644
--- a/dev-haskell/pandoc-lua-marshal/Manifest
+++ b/dev-haskell/pandoc-lua-marshal/Manifest
@@ -1 +1,2 @@
DIST pandoc-lua-marshal-0.1.6.tar.gz 41737 BLAKE2B 878f28c9f20b752f09c9c94215a90d7d2e43f32f598f95272aac0e1847d90cbe03df1a52cc93c025f24b8c439e633599d5b0d0b4c9f224f21c505b2a82cd8290 SHA512 be425707b82da8d82d544da5c67f58537ddaa7eabf2508ab4e7bd4c0cff05b394a784bea744e6f702047ee733e259369eef43de615436607b38ceb8bda89417d
+DIST pandoc-lua-marshal-0.2.2.tar.gz 38236 BLAKE2B 34685d34caa523390639fcdbf98faa19ef4f91f7bfab8e3a99016562280712409a2ddedc45be370f30165e66af849cd9e4d8c4069f1020c604ca2974236aeee3 SHA512 4a861beb82d2abd95c4c671c9962c99d5302d1fa44de7d80e6e0896c172a6cd3c3758fc4b51b29667dcec1a6d51385cbe8d8e53c15e6eab761840e39270cfe3d
diff --git a/dev-haskell/pandoc-lua-marshal/metadata.xml b/dev-haskell/pandoc-lua-marshal/metadata.xml
index 937381521944..b4ca44993479 100644
--- a/dev-haskell/pandoc-lua-marshal/metadata.xml
+++ b/dev-haskell/pandoc-lua-marshal/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">pandoc-lua-marshal</remote-id>
+ <remote-id type="github">pandoc/pandoc-lua-marshal</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.2.2.ebuild b/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.2.2.ebuild
new file mode 100644
index 000000000000..d240a29a02ac
--- /dev/null
+++ b/dev-haskell/pandoc-lua-marshal/pandoc-lua-marshal-0.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.2.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Use pandoc types in Lua"
+HOMEPAGE="https://github.com/pandoc/pandoc-lua-marshal"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/aeson-1.5:=[profile?] <dev-haskell/aeson-2.2:=[profile?]
+ >=dev-haskell/hslua-2.2:=[profile?] <dev-haskell/hslua-2.4:=[profile?]
+ >=dev-haskell/hslua-list-1.1:=[profile?] <dev-haskell/hslua-list-1.2:=[profile?]
+ >=dev-haskell/hslua-marshalling-2.2:=[profile?] <dev-haskell/hslua-marshalling-2.4:=[profile?]
+ >=dev-haskell/lua-2.2:=[profile?] <dev-haskell/lua-2.4:=[profile?]
+ >=dev-haskell/pandoc-types-1.23:=[profile?] <dev-haskell/pandoc-types-1.24:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+ >=dev-haskell/text-1.1.1.0:=[profile?] <dev-haskell/text-2.1:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ test? ( >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.15
+ >=dev-haskell/tasty-0.11
+ >=dev-haskell/tasty-hunit-0.9
+ >=dev-haskell/tasty-lua-1.0
+ >=dev-haskell/tasty-quickcheck-0.8 <dev-haskell/tasty-quickcheck-0.11 )
+"