summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:04:54 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:08:58 +0100
commit148bf291df46d3fb749d3626f3d5d841270de7df (patch)
tree8b7ddf9d20230e33376dfdb6396aa5b30201a0a8 /dev-haskell/xml-conduit
parentdev-haskell/pandoc-types: add 1.23.1 (diff)
downloadgentoo-148bf291df46d3fb749d3626f3d5d841270de7df.tar.gz
gentoo-148bf291df46d3fb749d3626f3d5d841270de7df.tar.bz2
gentoo-148bf291df46d3fb749d3626f3d5d841270de7df.zip
dev-haskell/xml-conduit: add 1.9.1.3
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/xml-conduit')
-rw-r--r--dev-haskell/xml-conduit/Manifest1
-rw-r--r--dev-haskell/xml-conduit/metadata.xml1
-rw-r--r--dev-haskell/xml-conduit/xml-conduit-1.9.1.3.ebuild38
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/xml-conduit/Manifest b/dev-haskell/xml-conduit/Manifest
index 63dda6f8ccdc..4a24062d5610 100644
--- a/dev-haskell/xml-conduit/Manifest
+++ b/dev-haskell/xml-conduit/Manifest
@@ -1 +1,2 @@
DIST xml-conduit-1.9.1.1.tar.gz 42901 BLAKE2B 2dacf27f6373827b779492130b837d3b5bc7adce599820b310cebedc8b1cf525ef300c5d6e65acafb5579a6f0922a47c749fbd8c49bbb623950d08dff63079c0 SHA512 4d75960eb400a4ac8cb13bb70f59b554659fa2a6165906f73097a2bc564505a1efa78e72b121d9ed0fd8b424ff25cd1d8368e6c1f2b6ffa4b0aa36f584727687
+DIST xml-conduit-1.9.1.3.tar.gz 44653 BLAKE2B 0796cd3b4c5daa7210027b0e17eb0870dbceeaa08d60672a5bd104a1e831c98f8fe5eba3f870f0d83ae508327daabe25fd6b87fcc644bcfdf1452af939d18687 SHA512 e864ce8c8785c11d81743b6cfaab91d863c728e7f3a955d9d5ce603bd36754dad2c7066fd60270ca2a39239cb314536b4bfc02f836d53a251c842741c4909324
diff --git a/dev-haskell/xml-conduit/metadata.xml b/dev-haskell/xml-conduit/metadata.xml
index d838ed84f839..305a8c24da46 100644
--- a/dev-haskell/xml-conduit/metadata.xml
+++ b/dev-haskell/xml-conduit/metadata.xml
@@ -21,6 +21,7 @@
Additionally, the xml-hamlet package &lt;http://hackage.haskell.org/package/xml-hamlet&gt; provides a more convenient syntax for creating XML documents. For a more thorough tutorial on this library, please see &lt;http://www.yesodweb.com/book/xml-enumerator&gt;.
</longdescription>
<upstream>
+ <remote-id type="hackage">xml-conduit</remote-id>
<remote-id type="github">snoyberg/xml</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-haskell/xml-conduit/xml-conduit-1.9.1.3.ebuild b/dev-haskell/xml-conduit/xml-conduit-1.9.1.3.ebuild
new file mode 100644
index 000000000000..78a0351adb9c
--- /dev/null
+++ b/dev-haskell/xml-conduit/xml-conduit-1.9.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+CABAL_FEATURES+=" rebuild-after-doc-workaround"
+inherit haskell-cabal
+
+DESCRIPTION="Pure-Haskell utilities for dealing with XML with the conduit package"
+HOMEPAGE="https://github.com/snoyberg/xml"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5:=[profile?]
+ >=dev-haskell/conduit-1.3:=[profile?] <dev-haskell/conduit-1.4:=[profile?]
+ >=dev-haskell/conduit-extra-1.3:=[profile?] <dev-haskell/conduit-extra-1.4:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ >=dev-haskell/resourcet-1.2:=[profile?] <dev-haskell/resourcet-1.4:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/xml-types-0.3.4:=[profile?] <dev-haskell/xml-types-0.4:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0 <dev-haskell/cabal-4
+ >=dev-haskell/cabal-doctest-1.0.9 <dev-haskell/cabal-doctest-1.1
+ test? ( >=dev-haskell/doctest-0.8
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit )
+"
+
+GHC_BOOTSTRAP_PACKAGES=( cabal-doctest )