summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jacl/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jacl/files')
-rw-r--r--dev-java/jacl/files/1.3.3-javacflags.patch36
-rw-r--r--dev-java/jacl/files/jacl-1.4.1-build.patch39
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-java/jacl/files/1.3.3-javacflags.patch b/dev-java/jacl/files/1.3.3-javacflags.patch
new file mode 100644
index 000000000000..600cabc2b7e8
--- /dev/null
+++ b/dev-java/jacl/files/1.3.3-javacflags.patch
@@ -0,0 +1,36 @@
+Index: Makefile.in
+===================================================================
+RCS file: /cvsroot/tcljava/tcljava/Makefile.in,v
+retrieving revision 1.60
+diff -u -r1.60 Makefile.in
+--- Makefile.in 5 Aug 2006 01:50:11 -0000 1.60
++++ Makefile.in 3 Apr 2007 08:51:22 -0000
+@@ -54,7 +54,7 @@
+ XTERM = xterm
+ JAVA_FLAGS = @JAVA_FLAGS@
+ JAVA_G_FLAGS = @JAVA_G_FLAGS@
+-JAVAC_FLAGS = @JAVAC_FLAGS@
++JAVAC_FLAGS ?= @JAVAC_FLAGS@
+ JAVAC_D_FLAG = @JAVAC_D_FLAG@
+ JAR_EXTRACT_FLAGS = @JAR_EXTRACT_FLAGS@
+ JAR_COMPRESS_FLAGS = @JAR_COMPRESS_FLAGS@
+Index: tcljava.m4
+===================================================================
+RCS file: /cvsroot/tcljava/tcljava/tcljava.m4,v
+retrieving revision 1.35
+diff -u -r1.35 tcljava.m4
+--- tcljava.m4 21 Aug 2006 22:26:37 -0000 1.35
++++ tcljava.m4 3 Apr 2007 08:51:28 -0000
+@@ -226,9 +226,9 @@
+ # Look for a setting for the CLASSPATH, we might need one to run JAVAC
+ AC_JAVA_CLASSPATH
+
+- # FIXME : add detection of command line arguments for JAVAC
+-
+- JAVAC_FLAGS=-g
++ if test "x${JAVAC_FLAGS}" = "x"; then
++ JAVAC_FLAGS=-g
++ fi
+ JAVAC_D_FLAG=-d
+
+ dnl Test out the Java compiler with an empty class
diff --git a/dev-java/jacl/files/jacl-1.4.1-build.patch b/dev-java/jacl/files/jacl-1.4.1-build.patch
new file mode 100644
index 000000000000..5f2ccf946492
--- /dev/null
+++ b/dev-java/jacl/files/jacl-1.4.1-build.patch
@@ -0,0 +1,39 @@
+diff -Naur jacl1.4.1.bak/Makefile.in jacl1.4.1/Makefile.in
+--- jacl1.4.1.bak/Makefile.in 2008-09-14 14:44:18.000000000 +1200
++++ jacl1.4.1/Makefile.in 2008-09-14 14:46:31.000000000 +1200
+@@ -54,7 +54,7 @@
+ XTERM = xterm
+ JAVA_FLAGS = @JAVA_FLAGS@
+ JAVA_G_FLAGS = @JAVA_G_FLAGS@
+-JAVAC_FLAGS = @JAVAC_FLAGS@
++JAVAC_FLAGS ?= @JAVAC_FLAGS@
+ JAVAC_D_FLAG = @JAVAC_D_FLAG@
+ JAR_EXTRACT_FLAGS = @JAR_EXTRACT_FLAGS@
+ JAR_COMPRESS_FLAGS = @JAR_COMPRESS_FLAGS@
+@@ -983,8 +983,8 @@
+ $(JAVAC) $(JAVAC_FLAGS) \
+ $(JAVAC_D_FLAG) $(TCLJAVA_BUILD_DIR) \
+ tcl/lang/*.java
+- mkdir $(TCLJAVA_BUILD_DIR)/tcl/lang/library
+- mkdir $(TCLJAVA_BUILD_DIR)/tcl/lang/library/java
++ mkdir -p $(TCLJAVA_BUILD_DIR)/tcl/lang/library
++ mkdir -p $(TCLJAVA_BUILD_DIR)/tcl/lang/library/java
+ cp -fr $(TCLJAVA_SRC_DIR)/tcl/lang/library/java/*.tcl \
+ $(TCLJAVA_BUILD_DIR)/tcl/lang/library/java
+
+diff -Naur jacl1.4.1.bak/tcljava.m4 jacl1.4.1/tcljava.m4
+--- jacl1.4.1.bak/tcljava.m4 2008-09-14 14:44:18.000000000 +1200
++++ jacl1.4.1/tcljava.m4 2008-09-14 14:44:30.000000000 +1200
+@@ -226,9 +226,9 @@
+ # Look for a setting for the CLASSPATH, we might need one to run JAVAC
+ AC_JAVA_CLASSPATH
+
+- # FIXME : add detection of command line arguments for JAVAC
+-
+- JAVAC_FLAGS=-g
++ if test "x${JAVAC_FLAGS}" = "x"; then
++ JAVAC_FLAGS=-g
++ fi
+ JAVAC_D_FLAG=-d
+
+ dnl Test out the Java compiler with an empty class