summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jexcelapi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jexcelapi')
-rw-r--r--dev-java/jexcelapi/Manifest1
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.6.8-r1.ebuild43
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.6.8.ebuild48
-rw-r--r--dev-java/jexcelapi/metadata.xml13
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-java/jexcelapi/Manifest b/dev-java/jexcelapi/Manifest
new file mode 100644
index 000000000000..f400130f3224
--- /dev/null
+++ b/dev-java/jexcelapi/Manifest
@@ -0,0 +1 @@
+DIST jexcelapi_2_6_8.tar.gz 1925926 SHA256 12f05e4453c203b91329a65329b564e86aaa77a005101f876c4de7b648c36034 SHA512 c649dcff8647530ca719f3e546d45ac585fed46d0a220763848f6d97b3f42c871b6520aee3575202598c7aba3391f647690075b6d9d52d1c2920817ff69548c1 WHIRLPOOL 24d60ad81961b224c6d63267ee4cb4432bca5bb89c1462797dc96dce4f7fb6403741c34819c78a36312a1df9f0fce756c1d026b1672c751fc8b3a42cc9f0e3c7
diff --git a/dev-java/jexcelapi/jexcelapi-2.6.8-r1.ebuild b/dev-java/jexcelapi/jexcelapi-2.6.8-r1.ebuild
new file mode 100644
index 000000000000..a8eaffc24a92
--- /dev/null
+++ b/dev-java/jexcelapi/jexcelapi-2.6.8-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P//-/_}"
+MY_P="${MY_P//./_}"
+
+DESCRIPTION="A Java API to read, write, and modify Excel spreadsheets"
+HOMEPAGE="http://jexcelapi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jexcelapi/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2.5"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${PN}
+
+EANT_BUILD_XML="build/build.xml"
+EANT_FILTER_COMPILER="jikes"
+EANT_BUILD_TARGET="jxl"
+EANT_DOC_TARGET="docs"
+
+java_prepare() {
+ find "${S}" -name "*.jar" -o -name "*.class" -delete || die
+}
+
+src_install() {
+ java-pkg_newjar jxl.jar ${PN}.jar
+
+ java-pkg_dohtml index.html tutorial.html
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc "${S}"/src/*
+}
diff --git a/dev-java/jexcelapi/jexcelapi-2.6.8.ebuild b/dev-java/jexcelapi/jexcelapi-2.6.8.ebuild
new file mode 100644
index 000000000000..a7c08f70fd3d
--- /dev/null
+++ b/dev-java/jexcelapi/jexcelapi-2.6.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P//-/_}"
+MY_P="${MY_P//./_}"
+
+DESCRIPTION="A Java API to read, write, and modify Excel spreadsheets"
+HOMEPAGE="http://jexcelapi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jexcelapi/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2.5"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ find -name "*.jar" | xargs rm -v
+ find -name "*.class" -delete
+ rm -fr docs
+
+ # sun-jdk-1.5/jikes fails
+ java-pkg_filter-compiler jikes
+}
+
+src_compile() {
+ eant -f build/build.xml jxl $(use_doc docs)
+}
+
+src_install() {
+ java-pkg_newjar jxl.jar ${PN}.jar
+
+ java-pkg_dohtml index.html tutorial.html
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc "${S}"/src/*
+}
diff --git a/dev-java/jexcelapi/metadata.xml b/dev-java/jexcelapi/metadata.xml
new file mode 100644
index 000000000000..51e8d055387b
--- /dev/null
+++ b/dev-java/jexcelapi/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <longdescription>
+
+ Java Excel API is a mature, open source java API enabling developers to read, write, and modifiy Excel spreadsheets dynamically. Now java developers can read Excel spreadsheets, modify them with a convenient and simple API, and write the changes to any output stream (e.g. disk, HTTP, database, or any socket).
+
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">jexcelapi</remote-id>
+ </upstream>
+</pkgmetadata>