summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-11-08 09:38:08 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-11-25 08:59:04 +0100
commitf8880555723ee71962cbabcd69144dc506ef1a65 (patch)
tree94d8aa5adf594c57e99f9f2180e7e93f381d2d45 /dev-java/jmock/jmock-1.2.0-r2.ebuild
parentsci-visualization/gcalc: style update, update EAPI 7 -> 8 (diff)
downloadgentoo-f8880555723ee71962cbabcd69144dc506ef1a65.tar.gz
gentoo-f8880555723ee71962cbabcd69144dc506ef1a65.tar.bz2
gentoo-f8880555723ee71962cbabcd69144dc506ef1a65.zip
dev-java/jmock: style update, update EAPI 7 -> 8
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/39233/commits/62bcb33317aae7acc15ea9b874ba3de3875e319d Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java/jmock/jmock-1.2.0-r2.ebuild')
-rw-r--r--dev-java/jmock/jmock-1.2.0-r2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-java/jmock/jmock-1.2.0-r2.ebuild b/dev-java/jmock/jmock-1.2.0-r2.ebuild
deleted file mode 100644
index 6ba5eb3a2018..000000000000
--- a/dev-java/jmock/jmock-1.2.0-r2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-JAVA_PKG_IUSE="doc source"
-
-inherit java-pkg-2 java-pkg-simple
-
-DESCRIPTION="Library for testing Java code using mock objects"
-HOMEPAGE="http://jmock.org/"
-SRC_URI="http://jmock.org/downloads/${P}-jars.zip"
-
-LICENSE="BSD"
-SLOT="1.0"
-KEYWORDS="amd64 arm64 ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-
-CDEPEND="dev-java/junit:0"
-
-RDEPEND=">=virtual/jre-1.8:*
- ${CDEPEND}"
-
-DEPEND="app-arch/unzip
- >=virtual/jdk-1.8:*
- ${CDEPEND}"
-
-S="${WORKDIR}/${P}"
-
-JAVA_SRC_DIR="src"
-JAVA_GENTOO_CLASSPATH="junit"
-
-PATCHES=(
- # This patch isn't changing the behaviour if jmock per se.
- # Only the formatting is altered.
- "${FILESDIR}"/${P}-AbstractMo.patch
-)
-
-src_unpack() {
- unpack ${A}
- unzip "${P}"/jmock-core-"${PV}".jar -d src || die
- mv src "${P}" || die
-}
-
-src_prepare() {
- default
- find -name "*.class" -delete || die
- rm *.jar || die
-}