summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jsap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jsap')
-rw-r--r--dev-java/jsap/Manifest1
-rw-r--r--dev-java/jsap/files/jsap-2.1-build.xml.patch22
-rw-r--r--dev-java/jsap/jsap-2.1.ebuild66
-rw-r--r--dev-java/jsap/metadata.xml8
4 files changed, 97 insertions, 0 deletions
diff --git a/dev-java/jsap/Manifest b/dev-java/jsap/Manifest
new file mode 100644
index 000000000000..03b03845a2dd
--- /dev/null
+++ b/dev-java/jsap/Manifest
@@ -0,0 +1 @@
+DIST JSAP-2.1-src.tar.gz 1281840 SHA256 5146bf75cba18fdf9299462a4127e95919c884494aaf3ed023cb2950217a0862 SHA512 5509d67b8af11cfbf94ca1a4d2b055b84c6c025ca26cd70390f63394d112a842fd39271181dfad0a88856964acd66f8abe49c72c58cc0086445d810837ba3352 WHIRLPOOL aecdc479d5d088429ca10a24a90b8aefc849ff7eef03276e9c2667a28420a2fefcf6d6541b1eee5d8c7891c3aa2c7392dc9e943084aaeac86bcc48d4a4d1dc78
diff --git a/dev-java/jsap/files/jsap-2.1-build.xml.patch b/dev-java/jsap/files/jsap-2.1-build.xml.patch
new file mode 100644
index 000000000000..8fae7e812bf7
--- /dev/null
+++ b/dev-java/jsap/files/jsap-2.1-build.xml.patch
@@ -0,0 +1,22 @@
+--- build.xml.original 2007-04-21 12:58:25.000000000 +0200
++++ build.xml 2007-04-21 13:08:39.000000000 +0200
+@@ -124,8 +124,8 @@
+ <!-- compile the JSAP API -->
+ <target name="compile-api" depends="init" >
+ <javac target="1.4" source="1.4" destdir="${build}" srcdir="${javasrc}">
+-<!-- <exclude name="${testFiles}" />
+- <exclude name="${exampleFiles}" /> -->
++ <exclude name="${testFiles}" />
++ <exclude name="${exampleFiles}" />
+ <classpath refid="lib.class.path" />
+ </javac>
+ <copy todir="${build}">
+@@ -168,7 +168,7 @@
+ </target>
+
+ <!-- make the jar -->
+- <target name="jar" depends="clean,test">
++ <target name="jar" depends="clean,compile-api">
+ <mkdir dir="${dist}"/>
+ <jar basedir="${build}" jarfile="${dist}/${jarname}">
+ <exclude name="${testFiles}" />
diff --git a/dev-java/jsap/jsap-2.1.ebuild b/dev-java/jsap/jsap-2.1.ebuild
new file mode 100644
index 000000000000..d558fc5d3b95
--- /dev/null
+++ b/dev-java/jsap/jsap-2.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Java Simple Arguments Parser (JSAP)"
+HOMEPAGE="http://sourceforge.net/projects/jsap"
+MY_PN=JSAP
+MY_P=${MY_PN}-${PV}
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+COMMON_DEP="
+ >=dev-java/ant-core-1.7.0
+ dev-java/xstream"
+
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}
+ =dev-java/snip-0.11*
+ =dev-java/rundoc-0.11*
+ test? (
+ dev-java/ant-junit
+ =dev-java/junit-3.8*
+ )"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-build.xml.patch"
+ java-ant_rewrite-classpath
+ cd "${S}/lib"
+
+ rm -v *.jar
+}
+
+EANT_BUILD_TARGET="jar"
+EANT_JAVADOC_TARGET="javadoc"
+EANT_ANT_TASKS="rundoc snip"
+EANT_GENTOO_CLASSPATH="ant-core xstream"
+
+src_test() {
+ ANT_TASKS="ant-junit rundoc snip" eant test
+}
+
+src_install() {
+ java-pkg_newjar dist/${MY_P}.jar
+
+ if use doc; then
+ dohtml doc/*.html
+ java-pkg_dojavadoc doc/javadoc
+ dosym /usr/share/doc/${PF}/html/api /usr/share/doc/${PF}/html/javadoc
+ fi
+
+ use source && java-pkg_dosrc src/java/com
+}
diff --git a/dev-java/jsap/metadata.xml b/dev-java/jsap/metadata.xml
new file mode 100644
index 000000000000..f67c76a9769d
--- /dev/null
+++ b/dev-java/jsap/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jsap</remote-id>
+ </upstream>
+</pkgmetadata>