summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/xalan/xalan-2.7.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/xalan/xalan-2.7.2.ebuild')
-rw-r--r--dev-java/xalan/xalan-2.7.2.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/dev-java/xalan/xalan-2.7.2.ebuild b/dev-java/xalan/xalan-2.7.2.ebuild
new file mode 100644
index 000000000000..1d9c5b5a44de
--- /dev/null
+++ b/dev-java/xalan/xalan-2.7.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# NOTE: Building the docs is much more hassle than it's worth. It
+# requires com.sun.image.codec, which has long gone from JDKs, and
+# Apache StyleBook, which is long dead though it is bundled here.
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2 versionator
+
+MY_PN="${PN}-j"
+MY_PV="$(replace_all_version_separators _)"
+MY_P="${MY_PN}_${MY_PV}"
+SRC_DIST="${MY_P}-src.tar.gz"
+BIN_DIST="${MY_P}-bin.zip"
+
+DESCRIPTION="Apache's XSLT processor for transforming XML documents into HTML, text, or other XML document types"
+HOMEPAGE="http://xalan.apache.org/"
+SRC_URI="mirror://apache/${PN}/${MY_PN}/source/${SRC_DIST}
+ doc? ( mirror://apache/${PN}/${MY_PN}/binaries/${BIN_DIST} )"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+CDEPEND="dev-java/javacup:0
+ dev-java/bcel:0"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.3
+ ~dev-java/xalan-serializer-${PV}:${SLOT}"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.3
+ doc? ( app-arch/unzip )"
+
+EANT_GENTOO_CLASSPATH="bcel,javacup"
+EANT_BUILD_TARGET="unbundledjar"
+EANT_DOC_TARGET=""
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ # disable building of serializer.jar
+ sed -i -e 's/depends="prepare,serializer.jar"/depends="prepare"/' \
+ build.xml || die "sed build.xml failed"
+
+ # remove bundled jars
+ find -name "*.jar" -delete || die
+ rm src/*.tar.gz || die
+}
+
+src_install() {
+ java-pkg_newjar build/${PN}-unbundled.jar
+ java-pkg_dolauncher ${PN} --main org.apache.xalan.xslt.Process
+ java-pkg_register-dependency ${PN}-serializer
+
+ dodoc NOTICE.txt readme.html
+ use doc && java-pkg_dohtml -r docs/*
+ use source && java-pkg_dosrc src/org
+}