summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-12-05 17:45:11 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-12-06 10:33:28 +0100
commitf0ae70071357d9de3f896ad1c019751ca5169bfa (patch)
tree364ee827f29260331ad3ebb8141720662551bc39 /dev-java
parentprofiles/package.mask: mask dev-ruby/semver2 for removal (diff)
downloadgentoo-f0ae70071357d9de3f896ad1c019751ca5169bfa.tar.gz
gentoo-f0ae70071357d9de3f896ad1c019751ca5169bfa.tar.bz2
gentoo-f0ae70071357d9de3f896ad1c019751ca5169bfa.zip
dev-java/gson: add 2.10.2_pre20231128
recent snapshot to pass tests previously failing with jdk:21 Bug: https://bugs.gentoo.org/916491 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/33589 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/gson/Manifest2
-rw-r--r--dev-java/gson/files/gson-2.10.2-GsonVersionDiagnosticsTest.patch40
-rw-r--r--dev-java/gson/gson-2.10.2_pre20231128.ebuild87
3 files changed, 129 insertions, 0 deletions
diff --git a/dev-java/gson/Manifest b/dev-java/gson/Manifest
index 357c58725dd7..b2d31e9659c7 100644
--- a/dev-java/gson/Manifest
+++ b/dev-java/gson/Manifest
@@ -1 +1,3 @@
+DIST gson-2.10.2_pre20231128.tar.gz 451312 BLAKE2B d16e0510e0806fd33e8d49b5a8fb73e969b89acb2598ca34a43faa97a09debc99466ab472176d60d617aa20b2190884def25881f0bf651e96be2c1bb9a976d70 SHA512 37f2073e5eee2cb85626040552ac750f4917abd05e3b7944c30a2d5ace6888424870a95a0ceba89bf2dadf9ab33e6bbae1591509b84f35aba4521780764c0877
DIST gson-parent-2.10.1.tar.gz 394777 BLAKE2B e118a7c39b17c4119b4140f3c105fef4c3cb07580dbc530d9bfd59edc4f152f62ac5ff93db1a3861c73758e369ecef4f8ed4e94d556869291469764ea848bbbd SHA512 074f40f7f9aa48daf5b5a3ec371713db02f6f8fceb959b01e8a16732862645d2350f3276ab7ff8021d48082f890b53c6e80d992af6af4b74e4646f85494b8e70
+DIST truth-1.1.3.jar 243021 BLAKE2B a59149038c62ef5dd352b13d4b393e1b7715fbafe5ed86ec2d16d722c738a31dcdca10132fc73b17b367ac4309e5407ba2e489f8d4c8fbca60ce5f35ae75d1e3 SHA512 f29a9fb070aff8a32358a7b6c8998c0095de5d8d68afa7f7bac759c7050309deff929e767657ecbbefd96163460f10255ca01bc567ab30df4834b9d916a4fae8
diff --git a/dev-java/gson/files/gson-2.10.2-GsonVersionDiagnosticsTest.patch b/dev-java/gson/files/gson-2.10.2-GsonVersionDiagnosticsTest.patch
new file mode 100644
index 000000000000..097e5f0098a9
--- /dev/null
+++ b/dev-java/gson/files/gson-2.10.2-GsonVersionDiagnosticsTest.patch
@@ -0,0 +1,40 @@
+There were 2 failures:
+1) testAssertionErrorInDeserializationPrintsVersion(com.google.gson.functional.GsonVersionDiagnosticsTest)
+expected to match: (\(GSON \d\.\d+\.\d)(?:[-.][A-Z]+)?\)$
+but was : (GSON 2.10.2_pre20231128)
+ at com.google.gson.functional.GsonVersionDiagnosticsTest.ensureAssertionErrorPrintsGsonVersion(GsonVersionDiagnosticsTest.java:91)
+ at com.google.gson.functional.GsonVersionDiagnosticsTest.testAssertionErrorInDeserializationPrintsVersion(GsonVersionDiagnosticsTest.java:79)
+2) testAssertionErrorInSerializationPrintsVersion(com.google.gson.functional.GsonVersionDiagnosticsTest)
+expected to match: (\(GSON \d\.\d+\.\d)(?:[-.][A-Z]+)?\)$
+but was : (GSON 2.10.2_pre20231128)
+ at com.google.gson.functional.GsonVersionDiagnosticsTest.ensureAssertionErrorPrintsGsonVersion(GsonVersionDiagnosticsTest.java:91)
+ at com.google.gson.functional.GsonVersionDiagnosticsTest.testAssertionErrorInSerializationPrintsVersion(GsonVersionDiagnosticsTest.java:71)
+
+FAILURES!!!
+Tests run: 1335, Failures: 2
+--- a/src/test/java/com/google/gson/functional/GsonVersionDiagnosticsTest.java
++++ b/src/test/java/com/google/gson/functional/GsonVersionDiagnosticsTest.java
+@@ -26,6 +26,7 @@ import com.google.gson.stream.JsonWriter;
+ import java.util.regex.Pattern;
+ import org.junit.Before;
+ import org.junit.Test;
++import org.junit.Ignore;
+
+ /**
+ * Functional tests to validate printing of Gson version on AssertionErrors
+@@ -65,13 +66,13 @@ public class GsonVersionDiagnosticsTest {
+ assertThat("(GSON 2.8.5-SNAPSHOT)").matches(GSON_VERSION_PATTERN);
+ }
+
+- @Test
++ @Test @Ignore
+ public void testAssertionErrorInSerializationPrintsVersion() {
+ AssertionError e = assertThrows(AssertionError.class, () -> gson.toJson(new TestType()));
+ ensureAssertionErrorPrintsGsonVersion(e);
+ }
+
+- @Test
++ @Test @Ignore
+ public void testAssertionErrorInDeserializationPrintsVersion() {
+ AssertionError e =
+ assertThrows(AssertionError.class, () -> gson.fromJson("{'a':'abc'}", TestType.class));
diff --git a/dev-java/gson/gson-2.10.2_pre20231128.ebuild b/dev-java/gson/gson-2.10.2_pre20231128.ebuild
new file mode 100644
index 000000000000..a8544b4d9312
--- /dev/null
+++ b/dev-java/gson/gson-2.10.2_pre20231128.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.google.code.gson:gson:${PV}"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Gson JSON library"
+HOMEPAGE="https://github.com/google/gson"
+# SRC_URI="https://github.com/google/gson/archive/gson-parent-${PV}.tar.gz"
+# S="${WORKDIR}/gson-gson-parent-${PV}/gson"
+MY_COMMIT="b17b1a0e98dcaf4b61823e1f0c29dda44c0ea3d5"
+SRC_URI="https://github.com/google/gson/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz
+ test? ( https://repo1.maven.org/maven2/com/google/truth/truth/1.1.3/truth-1.1.3.jar )"
+S="${WORKDIR}/gson-${MY_COMMIT}/gson"
+
+LICENSE="Apache-2.0"
+SLOT="2.6"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-java/error-prone-annotations:0
+ >=virtual/jdk-17:*
+ test? (
+ dev-java/guava:0
+ dev-java/guava-testlib:0
+ )"
+# src/test/java/com/google/gson/functional/Java17RecordTest.java:78:
+# error: records are not supported in -source 11
+RDEPEND=">=virtual/jre-17:*"
+
+DOCS=(
+ ../CHANGELOG.md
+ ../GsonDesignDocument.md
+ ../README.md
+ ../Troubleshooting.md
+ ../UserGuide.md
+)
+
+PATCHES=( "${FILESDIR}/gson-2.10.2-GsonVersionDiagnosticsTest.patch" )
+
+JAVA_CLASSPATH_EXTRA="error-prone-annotations"
+JAVA_RESOURCE_DIRS="src/main/resources"
+JAVA_SRC_DIR=(
+ "src/main/java"
+ "src/main/java-templates"
+)
+
+JAVA_TEST_EXCLUDES=(
+ # requires the test class to be obfuscated using proguard which we do not have atm
+ "com.google.gson.functional.EnumWithObfuscatedTest"
+ # testComGoogleGsonAnnotationsPackage(com.google.gson.regression.OSGiTest)
+ # junit.framework.AssertionFailedError: Cannot find com.google.gson OSGi bundle manifest
+ "com.google.gson.regression.OSGiTest"
+)
+JAVA_TEST_GENTOO_CLASSPATH="
+ guava
+ guava-testlib
+ junit-4
+"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+JAVA_TEST_SRC_DIR="src/test/java"
+
+src_prepare() {
+ default #780585
+ java-pkg-2_src_prepare
+ sed -e "s/\${project.version}/${PV}/g" \
+ -i src/main/java-templates/com/google/gson/internal/GsonBuildConfig.java \
+ || die "Failed to set version"
+}
+
+src_compile() {
+ if ! use test; then
+ JAVA_PKG_WANT_SOURCE="1.8"
+ JAVA_PKG_WANT_TARGET="1.8"
+ fi
+ java-pkg-simple_src_compile
+}
+
+src_test() {
+ JAVA_GENTOO_CLASSPATH_EXTRA="${DISTDIR}/truth-1.1.3.jar:testdata.jar"
+ java-pkg-simple_src_test
+}