summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-04 21:19:24 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-04 21:49:35 +0100
commit66a96f0da4782f480f9386ae29073496e2773e92 (patch)
treed66817704fabf06839c478543fbf4a86119a2567 /dev-lang/eisl
parentdev-lang/eisl: bump to 3.60 (diff)
downloadgentoo-66a96f0da4782f480f9386ae29073496e2773e92.tar.gz
gentoo-66a96f0da4782f480f9386ae29073496e2773e92.tar.bz2
gentoo-66a96f0da4782f480f9386ae29073496e2773e92.zip
dev-lang/eisl: sync live 9999
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/eisl')
-rw-r--r--dev-lang/eisl/eisl-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-lang/eisl/eisl-9999.ebuild b/dev-lang/eisl/eisl-9999.ebuild
index 987db06ada03..866b41aa1866 100644
--- a/dev-lang/eisl/eisl-9999.ebuild
+++ b/dev-lang/eisl/eisl-9999.ebuild
@@ -8,12 +8,14 @@ inherit toolchain-funcs
DESCRIPTION="Interpreter and compiler compatible with the ISLisp standard"
HOMEPAGE="https://github.com/sasagawa888/eisl/"
-if [[ ${PV} == *9999* ]] ; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
+
EGIT_REPO_URI="https://github.com/sasagawa888/${PN}.git"
else
SRC_URI="https://github.com/sasagawa888/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
+
KEYWORDS="~amd64 ~x86"
fi
@@ -26,7 +28,7 @@ DOCS=( README{,-ja}.md documents )
RDEPEND="sys-libs/ncurses:="
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${PN}-2.85-Makefile.patch )
+PATCHES=( "${FILESDIR}/${PN}-3.60-Makefile.patch" )
src_compile() {
emake CC="$(tc-getCC)" clean edlis eisl
@@ -38,7 +40,7 @@ src_install() {
# Compilation of ISLisp files on installation fails.
# Do not compile them and mimic "make install".
- insinto /usr/share/${PN}
+ insinto "/usr/share/${PN}"
doins -r library
doins fast.h ffi.h