summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-11-24 07:52:12 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-11-24 07:52:31 +0000
commita6af937438bbd6d88028a5cda7ff8ba20a16721e (patch)
treef61dbf43c5b4057f7ad27b426f0846e2046508c9 /dev-lang/ghc/ghc-8.2.1.ebuild
parentwww-apache/passenger: cleanup (diff)
downloadgentoo-a6af937438bbd6d88028a5cda7ff8ba20a16721e.tar.gz
gentoo-a6af937438bbd6d88028a5cda7ff8ba20a16721e.tar.bz2
gentoo-a6af937438bbd6d88028a5cda7ff8ba20a16721e.zip
dev-lang/ghc: drop LD_LIBRARY_PATH hack, bug #637532
LD_LIBRARY_PATH only worked for prefix systems using host's libc. On systems with prefix/libc it causes host's ld.so to load prefix's libc.so. They are incompatible as ld.so relies on presence of certain private symbols libc.so Reported-by: Horea Christian Bug: https://bugs.gentoo.org/637532 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-lang/ghc/ghc-8.2.1.ebuild')
-rw-r--r--dev-lang/ghc/ghc-8.2.1.ebuild11
1 files changed, 0 insertions, 11 deletions
diff --git a/dev-lang/ghc/ghc-8.2.1.ebuild b/dev-lang/ghc/ghc-8.2.1.ebuild
index 66a642bf9292..1b95d8e8ae07 100644
--- a/dev-lang/ghc/ghc-8.2.1.ebuild
+++ b/dev-lang/ghc/ghc-8.2.1.ebuild
@@ -324,17 +324,6 @@ relocate_ghc() {
relocate_path "/usr" "${WORKDIR}/usr" "$gp_back"
if use prefix; then
- # and insert LD_LIBRARY_PATH entry to EPREFIX dir tree
- # TODO: add the same for darwin's CHOST and it's DYLD_
- local new_ldpath='LD_LIBRARY_PATH="'${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)'${LD_LIBRARY_PATH:+:}${LD_LIBRARY_PATH}"\nexport LD_LIBRARY_PATH'
- sed -i -e '2i'"$new_ldpath" \
- "${WORKDIR}/usr/bin/ghc-${GHC_PV}" \
- "${WORKDIR}/usr/bin/ghci-${GHC_PV}" \
- "${WORKDIR}/usr/bin/ghc-pkg-${GHC_PV}" \
- "${WORKDIR}/usr/bin/hsc2hs" \
- "${WORKDIR}/usr/bin/runghc-${GHC_PV}" \
- "$gp_back" \
- || die "Adding LD_LIBRARY_PATH for wrappers failed"
hprefixify "${bin_libpath}"/${PN}*/settings
fi