summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-12-18 13:23:36 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-12-19 15:44:57 +0100
commitf5c72e1c152c51ac7a31234b79f2a7df3006c1ef (patch)
tree1ca8a426177ea2b9b51cddec37ac021124ebad55 /dev-lang/jsonnet/jsonnet-0.18.0-r1.ebuild
parentmedia-gfx/converseen: drop 0.9.9.0, 0.9.9.6 (diff)
downloadgentoo-f5c72e1c152c51ac7a31234b79f2a7df3006c1ef.tar.gz
gentoo-f5c72e1c152c51ac7a31234b79f2a7df3006c1ef.tar.bz2
gentoo-f5c72e1c152c51ac7a31234b79f2a7df3006c1ef.zip
dev-lang/jsonnet: drop 0.18.0-r1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-lang/jsonnet/jsonnet-0.18.0-r1.ebuild')
-rw-r--r--dev-lang/jsonnet/jsonnet-0.18.0-r1.ebuild106
1 files changed, 0 insertions, 106 deletions
diff --git a/dev-lang/jsonnet/jsonnet-0.18.0-r1.ebuild b/dev-lang/jsonnet/jsonnet-0.18.0-r1.ebuild
deleted file mode 100644
index 5d8c0d156382..000000000000
--- a/dev-lang/jsonnet/jsonnet-0.18.0-r1.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_OPTIONAL=1
-PYTHON_COMPAT=( pypy3 python3_{7..10} )
-
-inherit cmake toolchain-funcs flag-o-matic distutils-r1
-
-DESCRIPTION="A data templating language for app and tool developers"
-HOMEPAGE="https://jsonnet.org/"
-SRC_URI="https://github.com/google/jsonnet/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="custom-optimization doc examples python test"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm64 ppc64 x86"
-RDEPEND="
- dev-cpp/rapidyaml:=
- dev-cpp/nlohmann_json:=
- python? ( ${PYTHON_DEPS} )
-"
-
-DEPEND="
- ${RDEPEND}
- test? ( dev-cpp/gtest )
-"
-
-BDEPEND="
- python? (
- ${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-PATCHES=(
- "${FILESDIR}/jsonnet-0.12.1-dont-call-make-from-setuppy.patch"
- "${FILESDIR}/jsonnet-0.16.0-libdir.patch"
- "${FILESDIR}/jsonnet-0.16.0-cp-var.patch"
- "${FILESDIR}/jsonnet-0.18.0-unbundle.patch"
- "${FILESDIR}/jsonnet-0.18.0-gcc-13.patch"
-)
-
-distutils_enable_tests unittest
-
-src_prepare() {
- cmake_src_prepare
- use python && distutils-r1_src_prepare
-}
-
-src_configure() {
- use custom-optimization || replace-flags '-O*' -O3
- tc-export CC CXX
-
- local mycmakeargs=(
- -DUSE_SYSTEM_JSON=ON
- -DBUILD_STATIC_LIBS=OFF
- )
-
- if use test; then
- mycmakeargs+=(
- -DBUILD_TESTS=ON
- -DUSE_SYSTEM_GTEST=ON
- )
- else
- mycmakeargs+=(
- -DBUILD_TESTS=OFF
- )
- fi
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- use python && CMAKE_BUILD_DIR="${BUILD_DIR}" distutils-r1_src_compile
-}
-
-src_test() {
- cmake_src_test
- use python && CMAKE_BUILD_DIR="${BUILD_DIR}" distutils-r1_src_test
-}
-
-python_test() {
- LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}" "${EPYTHON}" -m unittest python._jsonnet_test -v \
- || die "Tests failed with ${EPYTHON}"
-}
-
-src_install() {
- cmake_src_install
- use python && distutils-r1_src_install
-
- if use doc; then
- find doc -name '.gitignore' -delete || die
- docinto html
- dodoc -r doc/.
- fi
- if use examples; then
- docinto examples
- dodoc -r examples/.
- fi
-}