summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lang/julia/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lang/julia/files')
-rw-r--r--dev-lang/julia/files/63julia-gentoo.el2
-rw-r--r--dev-lang/julia/files/julia-0.2.1-patchelf.patch16
-rw-r--r--dev-lang/julia/files/julia-0.2.1-readline63.patch17
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-lang/julia/files/63julia-gentoo.el b/dev-lang/julia/files/63julia-gentoo.el
new file mode 100644
index 000000000000..6b60749020ca
--- /dev/null
+++ b/dev-lang/julia/files/63julia-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'auto-mode-alist '("\\.jl$" . julia-mode))
diff --git a/dev-lang/julia/files/julia-0.2.1-patchelf.patch b/dev-lang/julia/files/julia-0.2.1-patchelf.patch
new file mode 100644
index 000000000000..663cf04b77db
--- /dev/null
+++ b/dev-lang/julia/files/julia-0.2.1-patchelf.patch
@@ -0,0 +1,16 @@
+--- deps/Makefile 2014-06-25 15:57:04.618463213 +0800
++++ deps/Makefile.new 2014-06-25 16:06:36.342318418 +0800
+@@ -42,14 +42,7 @@
+ endif
+ endif
+
+-ifeq ($(OS), Linux)
+-ifneq ($(shell patchelf --version 2>/dev/null), patchelf 0.6)
+-STAGE1_DEPS += patchelf
+-PATCHELF=$(BUILD)/bin/patchelf
+-else
+ PATCHELF=patchelf
+-endif
+-endif
+
+ ## USE_SYSTEM_LIBS options
diff --git a/dev-lang/julia/files/julia-0.2.1-readline63.patch b/dev-lang/julia/files/julia-0.2.1-readline63.patch
new file mode 100644
index 000000000000..cc9ede53f392
--- /dev/null
+++ b/dev-lang/julia/files/julia-0.2.1-readline63.patch
@@ -0,0 +1,17 @@
+Description: Fix FTBFS against readline 6.3
+Origin: backport, https://github.com/JuliaLang/julia/commit/d2552e0f03d1dc23d6bb0c89c39da3d73c7aa4e5
+Bug-Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=741824
+Last-Update: 2014-03-16
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/ui/repl-readline.c
++++ b/ui/repl-readline.c
+@@ -831,7 +831,7 @@ void jl_init_repl(int history)
+ rl_instream = fopen("/dev/null","r");
+ prompt_length = 7; // == strlen("julia> ")
+ init_history();
+- rl_startup_hook = (Function*)init_rl;
++ rl_startup_hook = (rl_hook_func_t*)init_rl;
+ }
+
+ static char *prompt_string=NULL;