summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-25 20:13:58 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-25 21:03:08 +0100
commit864978a817acd2cc8e55514272b19e07fe362d43 (patch)
treefa608fe32d9d325d47080d6b6146bdf04f627b86 /dev-lang/nim
parentdev-lang/nim: take maintainership (diff)
downloadgentoo-864978a817acd2cc8e55514272b19e07fe362d43.tar.gz
gentoo-864978a817acd2cc8e55514272b19e07fe362d43.tar.bz2
gentoo-864978a817acd2cc8e55514272b19e07fe362d43.zip
dev-lang/nim: bump to 1.6.2
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang/nim')
-rw-r--r--dev-lang/nim/Manifest1
-rw-r--r--dev-lang/nim/nim-1.6.2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-lang/nim/Manifest b/dev-lang/nim/Manifest
index 59723a5a1d1a..51a84293db2e 100644
--- a/dev-lang/nim/Manifest
+++ b/dev-lang/nim/Manifest
@@ -1 +1,2 @@
DIST nim-1.4.8.tar.xz 4786360 BLAKE2B 961b38275c4f9de87ac522c5b47368ce7f5543811a2dfd7b4f3fd79a104bcd0458caaaaab1705f99eb42c64735ca5f71d5018f8a8275a430d883233b28b1d412 SHA512 e6b245271495880f0eea271c46b4f5ce9168a421716a9a22367b6be3c2a9822937aad1f48eb61c151b040ac961728a89c8a6d143c8300057c0d8c1f2d66f3dd3
+DIST nim-1.6.2.tar.xz 5181616 BLAKE2B adedbcaad1b135b6f99459894856190103e2d2b678849e0418f77c02a54fde44224456ea13949f3fe9f5f020a90adde46593497895674bd9ae892b17708df292 SHA512 052b62c987035f7633f965356993cd4eec686f4f4f5c675cf966d82cb30fcf574045887a4402bcc20e487299fb5e8f65a921951c2dc21ac334e695e31d95d992
diff --git a/dev-lang/nim/nim-1.6.2.ebuild b/dev-lang/nim/nim-1.6.2.ebuild
new file mode 100644
index 000000000000..6e066c0a612d
--- /dev/null
+++ b/dev-lang/nim/nim-1.6.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 multiprocessing toolchain-funcs
+
+DESCRIPTION="compiled, garbage-collected systems programming language"
+HOMEPAGE="https://nim-lang.org/"
+SRC_URI="https://nim-lang.org/download/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug +readline"
+RESTRICT="test" # need to sort out depends and numerous failures
+
+RDEPEND="readline? ( sys-libs/readline:0= )"
+DEPEND="${DEPEND}"
+# test? ( net-libs/nodejs )
+
+PATCHES=( "${FILESDIR}"/${PN}-0.20.0-paths.patch )
+
+QA_FLAGS_IGNORED="
+usr/bin/atlas
+usr/bin/nim
+usr/bin/nim_dbg
+usr/bin/nimble
+usr/bin/nimgrep
+usr/bin/nimpretty
+usr/bin/nimsuggest
+usr/bin/testament
+"
+
+_run() {
+ echo "Running: ${@}"
+ PATH="${S}/bin:${PATH}" "${@}" || die "Failed: \"${*}\""
+}
+
+nim_use_enable() {
+ [[ -z "${2}" ]] && die "usage: nim_use_enable <USE flag> <compiler flag>"
+ use "${1}" && echo "-d:${2}"
+}
+
+src_configure() {
+ export XDG_CACHE_HOME="${T}/cache" #667182
+ unset NIMBLE_DIR
+ tc-export CC CXX LD
+
+ local build_type
+ if use debug ; then
+ build_type="debug"
+ else
+ build_type="release"
+ fi
+ export NIM_OPTS=( --parallelBuild:$(makeopts_jobs) -d:${build_type} )
+
+ # Override defaults
+ echo "gcc.exe = \"$(tc-getCC)\"" >> config/nim.cfg || die
+ echo "gcc.linkerexe = \"$(tc-getCC)\"" >> config/nim.cfg || die
+ echo "gcc.cpp.exe = \"$(tc-getCXX)\"" >> config/nim.cfg || die
+ echo "gcc.cpp.linkerexe = \"$(tc-getCXX)\"" >> config/nim.cfg || die
+}
+
+src_compile() {
+ _run bash ./build.sh
+
+ _run ./bin/nim ${NIM_OPTS[@]} compile koch
+ _run ./koch boot ${NIM_OPTS[@]} $(nim_use_enable readline useGnuReadline)
+ _run ./koch tools ${NIM_OPTS[@]}
+}
+
+src_install() {
+ _run ./koch install "${ED}"
+
+ # "./koch install" installs only "nim" binary
+ # but not the rest
+ exeinto /usr/bin
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == bin/nim ]] && continue
+ doexe "${exe}"
+ done
+
+ newbashcomp tools/nim.bash-completion nim
+ newbashcomp dist/nimble/nimble.bash-completion nimble
+}
+
+src_test() {
+ _run ./koch test
+}