summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-11 15:35:50 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-11 15:37:20 +0100
commit2ede26713b5d391957cc587b166d3aa1e6d5fb25 (patch)
treebafedd994090e5d2682407c67f2b06af212716c5 /dev-lang/python
parentsys-process/evisum: remove old 0.5.10 (diff)
downloadgentoo-2ede26713b5d391957cc587b166d3aa1e6d5fb25.tar.gz
gentoo-2ede26713b5d391957cc587b166d3aa1e6d5fb25.tar.bz2
gentoo-2ede26713b5d391957cc587b166d3aa1e6d5fb25.zip
dev-lang/python: Remove obsolete -L. hack
Closes: https://bugs.gentoo.org/770076 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.7.18-r6.ebuild5
-rw-r--r--dev-lang/python/python-3.10.0_alpha5.ebuild5
-rw-r--r--dev-lang/python/python-3.6.12-r2.ebuild5
-rw-r--r--dev-lang/python/python-3.7.9-r2.ebuild5
-rw-r--r--dev-lang/python/python-3.8.7-r1.ebuild5
-rw-r--r--dev-lang/python/python-3.9.1-r1.ebuild5
6 files changed, 0 insertions, 30 deletions
diff --git a/dev-lang/python/python-2.7.18-r6.ebuild b/dev-lang/python/python-2.7.18-r6.ebuild
index ea553c8e16d5..87697e77174e 100644
--- a/dev-lang/python/python-2.7.18-r6.ebuild
+++ b/dev-lang/python/python-2.7.18-r6.ebuild
@@ -174,11 +174,6 @@ src_configure() {
# http://bugs.python.org/issue15506
export ac_cv_path_PKG_CONFIG=$(tc-getPKG_CONFIG)
- # Set LDFLAGS so we link modules with -lpython2.7 correctly.
- # Needed on FreeBSD unless Python 2.7 is already installed.
- # Please query BSD team before removing this!
- append-ldflags "-L."
-
local dbmliborder
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"
diff --git a/dev-lang/python/python-3.10.0_alpha5.ebuild b/dev-lang/python/python-3.10.0_alpha5.ebuild
index df84b115ffd6..741cc079a7b8 100644
--- a/dev-lang/python/python-3.10.0_alpha5.ebuild
+++ b/dev-lang/python/python-3.10.0_alpha5.ebuild
@@ -153,11 +153,6 @@ src_configure() {
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
tc-export CXX
- # Set LDFLAGS so we link modules with -lpython3.2 correctly.
- # Needed on FreeBSD unless Python 3.2 is already installed.
- # Please query BSD team before removing this!
- append-ldflags "-L."
-
# Fix implicit declarations on cross and prefix builds. Bug #674070.
use ncurses && append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
diff --git a/dev-lang/python/python-3.6.12-r2.ebuild b/dev-lang/python/python-3.6.12-r2.ebuild
index 4a43ae082488..01b619ac4b9e 100644
--- a/dev-lang/python/python-3.6.12-r2.ebuild
+++ b/dev-lang/python/python-3.6.12-r2.ebuild
@@ -142,11 +142,6 @@ src_configure() {
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
tc-export CXX
- # Set LDFLAGS so we link modules with -lpython3.2 correctly.
- # Needed on FreeBSD unless Python 3.2 is already installed.
- # Please query BSD team before removing this!
- append-ldflags "-L."
-
local dbmliborder
if use gdbm; then
dbmliborder+="${dbmliborder:+:}gdbm"
diff --git a/dev-lang/python/python-3.7.9-r2.ebuild b/dev-lang/python/python-3.7.9-r2.ebuild
index d1a61f5ecdb8..3be1fff0bafc 100644
--- a/dev-lang/python/python-3.7.9-r2.ebuild
+++ b/dev-lang/python/python-3.7.9-r2.ebuild
@@ -134,11 +134,6 @@ src_configure() {
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
tc-export CXX
- # Set LDFLAGS so we link modules with -lpython3.2 correctly.
- # Needed on FreeBSD unless Python 3.2 is already installed.
- # Please query BSD team before removing this!
- append-ldflags "-L."
-
# Fix implicit declarations on cross and prefix builds. Bug #674070.
use ncurses && append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
diff --git a/dev-lang/python/python-3.8.7-r1.ebuild b/dev-lang/python/python-3.8.7-r1.ebuild
index 97ca965b7c5d..7d9a82ace38b 100644
--- a/dev-lang/python/python-3.8.7-r1.ebuild
+++ b/dev-lang/python/python-3.8.7-r1.ebuild
@@ -140,11 +140,6 @@ src_configure() {
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
tc-export CXX
- # Set LDFLAGS so we link modules with -lpython3.2 correctly.
- # Needed on FreeBSD unless Python 3.2 is already installed.
- # Please query BSD team before removing this!
- append-ldflags "-L."
-
# Fix implicit declarations on cross and prefix builds. Bug #674070.
use ncurses && append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw
diff --git a/dev-lang/python/python-3.9.1-r1.ebuild b/dev-lang/python/python-3.9.1-r1.ebuild
index 3bd43f252c8e..79ddedadff16 100644
--- a/dev-lang/python/python-3.9.1-r1.ebuild
+++ b/dev-lang/python/python-3.9.1-r1.ebuild
@@ -151,11 +151,6 @@ src_configure() {
# Export CXX so it ends up in /usr/lib/python3.X/config/Makefile.
tc-export CXX
- # Set LDFLAGS so we link modules with -lpython3.2 correctly.
- # Needed on FreeBSD unless Python 3.2 is already installed.
- # Please query BSD team before removing this!
- append-ldflags "-L."
-
# Fix implicit declarations on cross and prefix builds. Bug #674070.
use ncurses && append-cppflags -I"${ESYSROOT}"/usr/include/ncursesw