summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-09 07:41:28 +0000
committerSam James <sam@gentoo.org>2024-11-09 07:41:54 +0000
commit2d190c9e5b1db3292ea5d36f77a314eee019f99d (patch)
treea7bc8b6623abe4f93a0bc1b8195423e5bf0003f9 /dev-lang
parentwww-apps/nanoc-core: drop 4.12.20 (diff)
downloadgentoo-2d190c9e5b1db3292ea5d36f77a314eee019f99d.tar.gz
gentoo-2d190c9e5b1db3292ea5d36f77a314eee019f99d.tar.bz2
gentoo-2d190c9e5b1db3292ea5d36f77a314eee019f99d.zip
dev-lang/rust-common: avoid unpacking whole archive
Reported by mgorny (and suggested fix is by him): unpack just cargo.bashcomp.sh from the distfile instead of the whole thing, that way we don't need chcek-reqs.eclass. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-common/rust-common-1.81.0.ebuild5
-rw-r--r--dev-lang/rust-common/rust-common-1.82.0.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-lang/rust-common/rust-common-1.81.0.ebuild b/dev-lang/rust-common/rust-common-1.81.0.ebuild
index ae917833b983..b977c5aa1b92 100644
--- a/dev-lang/rust-common/rust-common-1.81.0.ebuild
+++ b/dev-lang/rust-common/rust-common-1.81.0.ebuild
@@ -34,6 +34,11 @@ RDEPEND="
!dev-lang/rust-bin:stable
"
+src_unpack() {
+ # Avoid unpacking the whole tarball which would need check-reqs
+ tar -xf "${DISTDIR}"/${SRC} ${SRC%%.tar.xz}/src/tools/cargo/src/etc/cargo.bashcomp.sh || die
+}
+
src_configure() {
:
}
diff --git a/dev-lang/rust-common/rust-common-1.82.0.ebuild b/dev-lang/rust-common/rust-common-1.82.0.ebuild
index 19197b4537fd..0d4b5aa7b8ae 100644
--- a/dev-lang/rust-common/rust-common-1.82.0.ebuild
+++ b/dev-lang/rust-common/rust-common-1.82.0.ebuild
@@ -35,6 +35,11 @@ RDEPEND="
!dev-lang/rust-bin:stable
"
+src_unpack() {
+ # Avoid unpacking the whole tarball which would need check-reqs
+ tar -xf "${DISTDIR}"/${SRC} ${SRC%%.tar.xz}/src/tools/cargo/src/etc/cargo.bashcomp.sh || die
+}
+
src_configure() {
:
}