summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-04-23 09:37:25 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-23 13:21:19 +0200
commit6f979c94f31f2462b1811d36b7d27eaa2550febd (patch)
tree6673691dae7c2b76c463c67f9a8a9caff81785d0 /dev-lang
parentdev-java/java-gnome: [QA] Add missing python metadata variables (diff)
downloadgentoo-6f979c94f31f2462b1811d36b7d27eaa2550febd.tar.gz
gentoo-6f979c94f31f2462b1811d36b7d27eaa2550febd.tar.bz2
gentoo-6f979c94f31f2462b1811d36b7d27eaa2550febd.zip
dev-lang/yasm: [QA] Add missing python metadata variables
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/yasm/yasm-1.2.0-r1.ebuild18
-rw-r--r--dev-lang/yasm/yasm-1.3.0.ebuild18
-rw-r--r--dev-lang/yasm/yasm-9999.ebuild20
3 files changed, 29 insertions, 27 deletions
diff --git a/dev-lang/yasm/yasm-1.2.0-r1.ebuild b/dev-lang/yasm/yasm-1.2.0-r1.ebuild
index 54cdb995623d..008d10fb17b1 100644
--- a/dev-lang/yasm/yasm-1.2.0-r1.ebuild
+++ b/dev-lang/yasm/yasm-1.2.0-r1.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
+
inherit autotools eutils python-r1
DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
@@ -14,17 +16,15 @@ LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
SLOT="0"
KEYWORDS="-* amd64 ~arm64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
IUSE="nls python"
-
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="nls? ( virtual/libintl )"
-DEPEND="nls? ( sys-devel/gettext )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/cython-0.14[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS )
+RDEPEND="
+ nls? ( virtual/libintl )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ python? ( >=dev-python/cython-0.14[${PYTHON_USEDEP}] )"
src_prepare() {
sed -i -e 's:xmlto:&dIsAbLe:' configure.ac || die #459940
diff --git a/dev-lang/yasm/yasm-1.3.0.ebuild b/dev-lang/yasm/yasm-1.3.0.ebuild
index 0d069a2a46e4..04266e13156d 100644
--- a/dev-lang/yasm/yasm-1.3.0.ebuild
+++ b/dev-lang/yasm/yasm-1.3.0.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
+
inherit python-r1
DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
@@ -13,17 +15,15 @@ LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
SLOT="0"
KEYWORDS="-* amd64 ~arm64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
IUSE="nls python"
-
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="nls? ( virtual/libintl )"
-DEPEND="nls? ( sys-devel/gettext )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/cython-0.14[${PYTHON_USEDEP}]
- )"
-
-DOCS=( AUTHORS )
+RDEPEND="
+ nls? ( virtual/libintl )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ python? ( >=dev-python/cython-0.14[${PYTHON_USEDEP}] )"
src_configure() {
use python && python_export_best
diff --git a/dev-lang/yasm/yasm-9999.ebuild b/dev-lang/yasm/yasm-9999.ebuild
index 148877d58ffb..b02b40c7c7a4 100644
--- a/dev-lang/yasm/yasm-9999.ebuild
+++ b/dev-lang/yasm/yasm-9999.ebuild
@@ -2,8 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
PYTHON_COMPAT=( python2_7 )
+
inherit autotools eutils python-r1
+
if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="git://github.com/yasm/yasm.git"
inherit git-2
@@ -18,21 +21,20 @@ HOMEPAGE="http://yasm.tortall.net/"
LICENSE="BSD-2 BSD || ( Artistic GPL-2 LGPL-2 )"
SLOT="0"
IUSE="nls python"
-
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-RDEPEND="nls? ( virtual/libintl )"
-DEPEND="nls? ( sys-devel/gettext )
- python? (
- ${PYTHON_DEPS}
- >=dev-python/cython-0.14[${PYTHON_USEDEP}]
- )"
+RDEPEND="
+ nls? ( virtual/libintl )
+ python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ python? ( >=dev-python/cython-0.14[${PYTHON_USEDEP}] )"
+
if [[ ${PV} == 9999* ]]; then
DEPEND="${DEPEND} ${PYTHON_DEPS} app-text/xmlto app-text/docbook-xml-dtd:4.1.2"
fi
-DOCS=( AUTHORS )
-
src_prepare() {
if ! [[ ${PV} == 9999* ]]; then
sed -i -e 's:xmlto:&dIsAbLe:' configure.ac || die #459940