summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-03 04:24:47 +0000
committerSam James <sam@gentoo.org>2022-02-03 04:24:47 +0000
commit3414b1d35d6862ed5a5ad5251a60bc18b2e2be71 (patch)
treeaa22f661441d048af6eb3c0535bfeed4ad450887 /dev-libs/boost
parentdev-python/pillow: add 9.0.1 (diff)
downloadgentoo-3414b1d35d6862ed5a5ad5251a60bc18b2e2be71.tar.gz
gentoo-3414b1d35d6862ed5a5ad5251a60bc18b2e2be71.tar.bz2
gentoo-3414b1d35d6862ed5a5ad5251a60bc18b2e2be71.zip
dev-libs/boost: fix musl build for 1.78
Closes: https://bugs.gentoo.org/829147 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.78.0-r2.ebuild2
-rw-r--r--dev-libs/boost/files/boost-1.78.0-interprocess-musl-include.patch25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/boost/boost-1.78.0-r2.ebuild b/dev-libs/boost/boost-1.78.0-r2.ebuild
index a67156cf87e9..53fbaeeddd56 100644
--- a/dev-libs/boost/boost-1.78.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.78.0-r2.ebuild
@@ -53,6 +53,8 @@ PATCHES=(
# Boost.MPI's __init__.py doesn't work on Py3
"${FILESDIR}"/${PN}-1.73-boost-mpi-python-PEP-328.patch
"${FILESDIR}"/${PN}-1.74-CVE-2012-2677.patch
+
+ "${FILESDIR}"/${P}-interprocess-musl-include.patch
)
python_bindings_needed() {
diff --git a/dev-libs/boost/files/boost-1.78.0-interprocess-musl-include.patch b/dev-libs/boost/files/boost-1.78.0-interprocess-musl-include.patch
new file mode 100644
index 000000000000..85d25861f11b
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.78.0-interprocess-musl-include.patch
@@ -0,0 +1,25 @@
+https://github.com/boostorg/interprocess/commit/d002a0d929ecb031843d806c2bda69e013442e13
+https://bugs.gentoo.org/829147
+
+From: Leonardo Neumann <leonardo@neumann.dev.br>
+Date: Mon, 13 Dec 2021 01:07:20 -0300
+Subject: [PATCH] Fix missing sys/stat.h include on musl-based systems
+
+Boost 1.78.0 fails to build on musl-based systems because musl does
+not include sys/stat.h by default.
+
+Fixes #161 ("Boost compiler error")
+--- a/boost/interprocess/permissions.hpp
++++ b/boost/interprocess/permissions.hpp
+@@ -29,6 +29,10 @@
+
+ #include <boost/interprocess/detail/win32_api.hpp>
+
++#else
++
++#include <sys/stat.h>
++
+ #endif
+
+ #endif //#ifndef BOOST_INTERPROCESS_DOXYGEN_INVOKED
+