summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-02-15 21:24:13 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-02-16 16:54:30 +0000
commit6d7aed71f5beb7f9859630b85c565c5dee2cd579 (patch)
treedfbbc38746459e8abf241255c9fb98204e291e42 /dev-libs/c-blosc/files
parentdev-util/conan: quoting (diff)
downloadgentoo-6d7aed71f5beb7f9859630b85c565c5dee2cd579.tar.gz
gentoo-6d7aed71f5beb7f9859630b85c565c5dee2cd579.tar.bz2
gentoo-6d7aed71f5beb7f9859630b85c565c5dee2cd579.zip
dev-libs/c-blosc: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-libs/c-blosc/files')
-rw-r--r--dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch b/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch
new file mode 100644
index 000000000000..d385d5263710
--- /dev/null
+++ b/dev-libs/c-blosc/files/c-blosc-1.11.2-fix-build-system.patch
@@ -0,0 +1,21 @@
+Make the build system respect CFLAGS
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -244,16 +244,6 @@
+ endif()
+
+ # flags
+-# @TODO: set -Wall
+-# @NOTE: -O3 is enabled in Release mode (CMAKE_BUILD_TYPE="Release")
+-
+-# Set the "-msse2" build flag only if the CMAKE_C_FLAGS is not already set.
+-# Probably "-msse2" should be appended to CMAKE_C_FLAGS_RELEASE.
+-if(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
+- if(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
+- set(CMAKE_C_FLAGS -msse2 CACHE STRING "C flags." FORCE)
+- endif(NOT CMAKE_C_FLAGS AND COMPILER_SUPPORT_SSE2)
+-endif(CMAKE_C_COMPILER_ID STREQUAL GNU OR CMAKE_C_COMPILER_ID STREQUAL Clang OR CMAKE_C_COMPILER_ID STREQUAL Intel)
+
+ if(MSVC)
+ if(NOT CMAKE_C_FLAGS)