summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/dee
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/dee')
-rw-r--r--dev-libs/dee/Manifest1
-rw-r--r--dev-libs/dee/dee-1.2.7.ebuild93
-rw-r--r--dev-libs/dee/files/dee-1.0.10-gcc-4.5.patch30
-rw-r--r--dev-libs/dee/files/dee-1.0.10-vapigen.patch16
-rw-r--r--dev-libs/dee/metadata.xml10
5 files changed, 150 insertions, 0 deletions
diff --git a/dev-libs/dee/Manifest b/dev-libs/dee/Manifest
new file mode 100644
index 000000000000..9398a6ac1ac3
--- /dev/null
+++ b/dev-libs/dee/Manifest
@@ -0,0 +1 @@
+DIST dee-1.2.7.tar.gz 712167 SHA256 1bf0336ce684aa0f48d6eae2469628c1a9b43695a77443bc31a5790aa673bf8a SHA512 32e25a2164cf052a76cf021006e1cdeca9b25081d19b5e7f1700308ddc21f65b4b5230fef0197fdda1739281b96af39fbf9d1df50d79c812cea8a6f60fbb7248 WHIRLPOOL 95d471be45a338200f5f88be45e8d7f333e34912c55f9b07863e903d86d1936ccfd013b68a6b22931c80f60a59e8447e11472c61e4de975a8731317924c8970d
diff --git a/dev-libs/dee/dee-1.2.7.ebuild b/dev-libs/dee/dee-1.2.7.ebuild
new file mode 100644
index 000000000000..bc156e906901
--- /dev/null
+++ b/dev-libs/dee/dee-1.2.7.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+AUTOTOOLS_AUTORECONF=y
+
+inherit autotools-utils vala python-r1
+
+DESCRIPTION="Provide objects allowing to create Model-View-Controller type programs across DBus"
+HOMEPAGE="https://launchpad.net/dee/"
+SRC_URI="https://launchpad.net/dee/1.0/${PV}/+download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="doc debug examples +icu introspection static-libs test"
+
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/icu:=
+ introspection? (
+ ${PYTHON_DEPS}
+ dev-libs/gobject-introspection
+ )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ doc? ( dev-util/gtk-doc )
+ test? (
+ dev-libs/gtx
+ dev-util/dbus-test-runner
+ )"
+
+src_prepare() {
+ sed \
+ -e '/GCC_FLAGS/s:-g::' \
+ -e 's:vapigen:${VAPIGEN}:g' \
+ -i configure.ac || die
+
+ sed \
+ -e 's:bindings::g' \
+ -i Makefile.am || die
+
+ vala_src_prepare
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-silent-rules
+ $(use_enable debug trace-log)
+ $(use_enable doc gtk-doc)
+ $(use_enable icu)
+ $(use_enable test tests)
+# $(use_enable test extended-tests)
+ )
+ autotools-utils_src_configure
+ use introspection && python_copy_sources
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ compilation() {
+ cd bindings || die
+ emake \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ use introspection && python_foreach_impl run_in_build_dir compilation
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PN}/
+ doins -r examples
+ fi
+
+ installation() {
+ cd bindings || die
+ emake \
+ PYGI_OVERRIDES_DIR="$(python_get_sitedir)"/gi/overrides \
+ DESTDIR="${D}" \
+ install
+ }
+ use introspection && python_foreach_impl run_in_build_dir installation
+}
diff --git a/dev-libs/dee/files/dee-1.0.10-gcc-4.5.patch b/dev-libs/dee/files/dee-1.0.10-gcc-4.5.patch
new file mode 100644
index 000000000000..11854a96e3b2
--- /dev/null
+++ b/dev-libs/dee/files/dee-1.0.10-gcc-4.5.patch
@@ -0,0 +1,30 @@
+ src/dee-filter.h | 2 +-
+ src/dee-model-reader.h | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/dee-filter.h b/src/dee-filter.h
+index de8d252..327f512 100644
+--- a/src/dee-filter.h
++++ b/src/dee-filter.h
+@@ -30,7 +30,7 @@
+
+ G_BEGIN_DECLS
+
+-typedef struct _DeeFilter DeeFilter;
++//typedef struct _DeeFilter DeeFilter;
+
+ /**
+ * DeeFilterMapFunc:
+diff --git a/src/dee-model-reader.h b/src/dee-model-reader.h
+index a249149..dd23de6 100644
+--- a/src/dee-model-reader.h
++++ b/src/dee-model-reader.h
+@@ -30,7 +30,7 @@
+
+ G_BEGIN_DECLS
+
+-typedef struct _DeeFilter DeeFilter;
++//typedef struct _DeeFilter DeeFilter;
+
+ /**
+ * DeeModelReaderFunc:
diff --git a/dev-libs/dee/files/dee-1.0.10-vapigen.patch b/dev-libs/dee/files/dee-1.0.10-vapigen.patch
new file mode 100644
index 000000000000..25fb7a97406a
--- /dev/null
+++ b/dev-libs/dee/files/dee-1.0.10-vapigen.patch
@@ -0,0 +1,16 @@
+ vapi/Makefile.am | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/vapi/Makefile.am b/vapi/Makefile.am
+index c384ecd..413a96a 100644
+--- a/vapi/Makefile.am
++++ b/vapi/Makefile.am
+@@ -6,7 +6,7 @@ if HAVE_INTROSPECTION
+ if HAVE_VAPIGEN
+
+ dee-1.0.vapi: $(top_builddir)/src/Dee-$(DEE_MAJOR_VERSION).$(DEE_MINOR_VERSION).gir $(srcdir)/Dee-1.0-custom.vala $(srcdir)/Dee-1.0.metadata
+- $(AM_V_GEN)$(VALA_API_GEN) --library dee-1.0 --metadatadir=$(srcdir) $(filter %.gir %.vala,$^)
++ $(AM_V_GEN)$(VALA_API_GEN) --library dee-1.0 --metadatadir=$(srcdir) $(filter %.gir %.vala,$^) --pkg gtk+-3.0
+ @touch $@
+
+ endif
diff --git a/dev-libs/dee/metadata.xml b/dev-libs/dee/metadata.xml
new file mode 100644
index 000000000000..d626400f272d
--- /dev/null
+++ b/dev-libs/dee/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">dee</remote-id>
+ </upstream>
+</pkgmetadata>