summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-10 16:18:23 +0100
committerSam James <sam@gentoo.org>2022-09-10 16:18:47 +0100
commit3f9009693aece82f013a453c7e21618820d7daa6 (patch)
tree7fd128155e0ab3c232a9c68e9adbe2dd624a4af2 /dev-libs/elfutils
parentdev-ml/batteries: disable ocamlopt if asked on install too (diff)
downloadgentoo-3f9009693aece82f013a453c7e21618820d7daa6.tar.gz
gentoo-3f9009693aece82f013a453c7e21618820d7daa6.tar.bz2
gentoo-3f9009693aece82f013a453c7e21618820d7daa6.zip
dev-libs/elfutils: fix configure args
Closes: https://bugs.gentoo.org/869530 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/elfutils')
-rw-r--r--dev-libs/elfutils/elfutils-0.187-r2.ebuild (renamed from dev-libs/elfutils/elfutils-0.187-r1.ebuild)32
1 files changed, 19 insertions, 13 deletions
diff --git a/dev-libs/elfutils/elfutils-0.187-r1.ebuild b/dev-libs/elfutils/elfutils-0.187-r2.ebuild
index 3fcb27f7b6a2..701a5bc1f9ad 100644
--- a/dev-libs/elfutils/elfutils-0.187-r1.ebuild
+++ b/dev-libs/elfutils/elfutils-0.187-r2.ebuild
@@ -76,20 +76,26 @@ src_configure() {
}
multilib_src_configure() {
- # Valgrind option is just for running tests under it; dodgy under sandbox
- # and indeed even w/ glibc with newer instructions.
- ECONF_SOURCE="${S}" econf \
- $(use_enable nls) \
- --disable-debuginfod \
- --disable-libdebuginfod \
- # explicitly disable thread safety: not recommended by upstream
- --disable-thread-safety \
- --disable-valgrind \
- --program-prefix="eu-" \
- --with-zlib \
- $(use_with bzip2 bzlib) \
- $(use_with lzma) \
+ local myeconfargs=(
+ $(use_enable nls)
+ --disable-debuginfod
+ --disable-libdebuginfod
+
+ # explicitly disable thread safety, it's not recommended by upstream
+ # doesn't build either on musl.
+ --disable-thread-safety
+
+ # Valgrind option is just for running tests under it; dodgy under sandbox
+ # and indeed even w/ glibc with newer instructions.
+ --disable-valgrind
+ --program-prefix="eu-"
+ --with-zlib
+ $(use_with bzip2 bzlib)
+ $(use_with lzma)
$(use_with zstd)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}
multilib_src_test() {