summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2018-09-09 13:40:28 +0100
committerAmy Liffey <amynka@gentoo.org>2018-09-09 14:04:50 +0100
commit62b4c50953573f6c9276446ea9ea3cfed5322f49 (patch)
tree5b6277df9af38119cb3a1018cbed1ad3c37742a5 /dev-libs/g-wrap/g-wrap-1.9.15.ebuild
parentnet-im/telegram-desktop-bin: Disable minor arches support via KEYWORDS (diff)
downloadgentoo-62b4c50953573f6c9276446ea9ea3cfed5322f49.tar.gz
gentoo-62b4c50953573f6c9276446ea9ea3cfed5322f49.tar.bz2
gentoo-62b4c50953573f6c9276446ea9ea3cfed5322f49.zip
dev-libs/g-wrap: version bump 1.9.15
Bug: https://bugs.gentoo.org/640444 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-libs/g-wrap/g-wrap-1.9.15.ebuild')
-rw-r--r--dev-libs/g-wrap/g-wrap-1.9.15.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/g-wrap/g-wrap-1.9.15.ebuild b/dev-libs/g-wrap/g-wrap-1.9.15.ebuild
new file mode 100644
index 000000000000..5a49fcadfff8
--- /dev/null
+++ b/dev-libs/g-wrap/g-wrap-1.9.15.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A tool for exporting C libraries into Scheme"
+HOMEPAGE="http://www.nongnu.org/g-wrap/"
+SRC_URI="http://download.savannah.gnu.org/releases/g-wrap/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# guile-lib for srfi-34, srfi-35
+RDEPEND="
+ dev-libs/glib:2
+ dev-scheme/guile-lib
+ dev-scheme/guile[deprecated]
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/indent"
+
+src_configure() {
+ econf --disable-Werror --with-glib
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}