summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-23 22:13:53 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-24 19:20:15 -0700
commitb0aa96688d7af4a926fd06df082a6de9ae57bec8 (patch)
treee1982835d714ad5d52bd9cfe45313d768c5dd791 /dev-libs/gobject-introspection-common/gobject-introspection-common-1.64.0.ebuild
parentnet-mail/b4: import 0.3.4 (diff)
downloadgentoo-b0aa96688d7af4a926fd06df082a6de9ae57bec8.tar.gz
gentoo-b0aa96688d7af4a926fd06df082a6de9ae57bec8.tar.bz2
gentoo-b0aa96688d7af4a926fd06df082a6de9ae57bec8.zip
dev-libs/gobject-introspection-common: Version bump to 1.64.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/gobject-introspection-common/gobject-introspection-common-1.64.0.ebuild')
-rw-r--r--dev-libs/gobject-introspection-common/gobject-introspection-common-1.64.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/gobject-introspection-common/gobject-introspection-common-1.64.0.ebuild b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.64.0.ebuild
new file mode 100644
index 000000000000..70eb0234f5dc
--- /dev/null
+++ b/dev-libs/gobject-introspection-common/gobject-introspection-common-1.64.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GNOME_ORG_MODULE="gobject-introspection"
+
+inherit gnome.org
+
+DESCRIPTION="Build infrastructure for GObject Introspection"
+HOMEPAGE="https://wiki.gnome.org/Projects/GObjectIntrospection"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<${CATEGORY}/${GNOME_ORG_MODULE}-${PV}"
+# Use !<${PV} because mixing gobject-introspection with different version of -common can cause issues like:
+# https://forums.gentoo.org/viewtopic-p-7421930.html
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/aclocal
+ doins m4/introspection.m4
+
+ insinto /usr/share/gobject-introspection-1.0
+ doins Makefile.introspection
+}