summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/grantlee
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/grantlee')
-rw-r--r--dev-libs/grantlee/Manifest2
-rw-r--r--dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch46
-rw-r--r--dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch14
-rw-r--r--dev-libs/grantlee/files/grantlee-slot.patch40
-rw-r--r--dev-libs/grantlee/grantlee-0.4.0.ebuild54
-rw-r--r--dev-libs/grantlee/grantlee-5.0.0.ebuild58
-rw-r--r--dev-libs/grantlee/metadata.xml5
7 files changed, 219 insertions, 0 deletions
diff --git a/dev-libs/grantlee/Manifest b/dev-libs/grantlee/Manifest
new file mode 100644
index 000000000000..be3a94f74587
--- /dev/null
+++ b/dev-libs/grantlee/Manifest
@@ -0,0 +1,2 @@
+DIST grantlee-0.4.0.tar.gz 1171445 SHA256 13a2d8121392404bb3be4ed470b211bc098cd98da795ef7bf41517d2fb640d3f SHA512 6ff539eb7aaf366487214b02131d67b9967713c42d20314ff56129e9543516fdf2d129b9c3015f0959c89c6f0ee9ad085af91fed4293bd0613d8e888bc850ca7 WHIRLPOOL ee639a72c6f785559b427a2f13483c256e19dbeb270ff34118a81547ea1f31a69aeaed7c58a2d89952b79d58e3acc88ef44f06cac32739747c7920ef66d621b0
+DIST grantlee-5.0.0.tar.gz 1166498 SHA256 eaf22ba92e53b8eb5dd8bca045fe81b734d3445445ed9e0c1af2a0a7c375b161 SHA512 29b73fe4ee1b6e814ca91e4a3732208bada9b64bc8ace506bd8e888927b3fcd1a539e4ec03488901815692bd47424d8176fb2d6766461011e40fb33b221f6be4 WHIRLPOOL 418cb19061990a39c24d6be42c86f7f63a11d4451434dc2616072a4498268a1bc1de0d5de9163d2980420c1cc955e2f700a4722e19ebbeded5f0aa6a7393eb48
diff --git a/dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch b/dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch
new file mode 100644
index 000000000000..6af42cbab3fb
--- /dev/null
+++ b/dev-libs/grantlee/files/grantlee-0.1.9-qt-test-optional.patch
@@ -0,0 +1,46 @@
+From ab40a1ce4bff38fe6c19931bcdb46cdf754e29ed Mon Sep 17 00:00:00 2001
+From: Johannes Huber <johu@gentoo.org>
+Date: Thu, 22 Mar 2012 11:37:57 +0100
+Subject: [PATCH] Search only for qt-test if test build option is enabled.
+
+Build fails on systems were no qt-test is installed and the build option
+for tests is disabled. See downstream bug report
+https://bugs.gentoo.org/show_bug.cgi?id=409131.
+---
+ templates/CMakeLists.txt | 6 +++++-
+ textdocument/CMakeLists.txt | 6 +++++-
+ 2 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/templates/CMakeLists.txt b/templates/CMakeLists.txt
+index 0594cc3..eec0f12 100644
+--- a/templates/CMakeLists.txt
++++ b/templates/CMakeLists.txt
+@@ -1,5 +1,9 @@
+
+-find_package(Qt4 4.5.0 REQUIRED QtCore QtScript QtTest)
++if (BUILD_TESTS)
++ find_package(Qt4 4.5.0 REQUIRED QtCore QtScript QtTest)
++else (BUILD_TESTS)
++ find_package(Qt4 4.5.0 REQUIRED QtCore QtScript)
++endif (BUILD_TESTS)
+
+ include(${Grantlee_USE_FILE})
+
+diff --git a/textdocument/CMakeLists.txt b/textdocument/CMakeLists.txt
+index d456663..8fa2892 100644
+--- a/textdocument/CMakeLists.txt
++++ b/textdocument/CMakeLists.txt
+@@ -1,5 +1,9 @@
+
+-find_package(Qt4 4.5.0 REQUIRED QtCore QtGui QtTest)
++if (BUILD_TESTS)
++ find_package(Qt4 4.5.0 REQUIRED QtCore QtScript QtTest)
++else (BUILD_TESTS)
++ find_package(Qt4 4.5.0 REQUIRED QtCore QtScript)
++endif (BUILD_TESTS)
+
+ include(${QT_USE_FILE})
+
+--
+1.7.9.4
+
diff --git a/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch b/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
new file mode 100644
index 000000000000..a25f52b3c63d
--- /dev/null
+++ b/dev-libs/grantlee/files/grantlee-0.3.0-nonfatal-warnings.patch
@@ -0,0 +1,14 @@
+diff -ruN grantlee-0.3.0.orig/CMakeLists.txt grantlee-0.3.0/CMakeLists.txt
+--- grantlee-0.3.0.orig/CMakeLists.txt 2012-11-01 21:14:18.000000000 +0100
++++ grantlee-0.3.0/CMakeLists.txt 2013-03-09 12:25:56.498096399 +0100
+@@ -62,8 +62,8 @@
+ endif()
+
+ if (NOT APPLE)
+- set ( CMAKE_SHARED_LINKER_FLAGS "-Wl,--fatal-warnings -Wl,--no-undefined ${CMAKE_SHARED_LINKER_FLAGS}")
+- set ( CMAKE_MODULE_LINKER_FLAGS "-Wl,--fatal-warnings -Wl,--no-undefined ${CMAKE_MODULE_LINKER_FLAGS}")
++ set ( CMAKE_SHARED_LINKER_FLAGS "-Wl,--no-undefined ${CMAKE_SHARED_LINKER_FLAGS}")
++ set ( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined ${CMAKE_MODULE_LINKER_FLAGS}")
+ endif ()
+
+ if (NOT MINGW)
diff --git a/dev-libs/grantlee/files/grantlee-slot.patch b/dev-libs/grantlee/files/grantlee-slot.patch
new file mode 100644
index 000000000000..814fb9d63b90
--- /dev/null
+++ b/dev-libs/grantlee/files/grantlee-slot.patch
@@ -0,0 +1,40 @@
+Install headers to a custom location to permit slotting with Qt4 version.
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 45f8673..7832a3b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -94,7 +94,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define suffix of library directory name (eg. '6
+ set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
+ set( PLUGIN_INSTALL_DIR lib${LIB_SUFFIX}/grantlee/${Grantlee_MAJOR_MINOR_VERSION_STRING} )
+ set( BIN_INSTALL_DIR bin )
+-set( INCLUDE_INSTALL_DIR include )
++set( INCLUDE_INSTALL_DIR include/grantlee5 )
+ set( DATA_INSTALL_DIR share/apps )
+
+ # set up RPATH/install_name_dir
+diff --git a/templates/lib/CMakeLists.txt b/templates/lib/CMakeLists.txt
+index 789205c..7045449 100644
+--- a/templates/lib/CMakeLists.txt
++++ b/templates/lib/CMakeLists.txt
+@@ -79,6 +79,7 @@ add_library(Grantlee5::Templates ALIAS Grantlee_Templates)
+ generate_export_header(Grantlee_Templates)
+ set_property(TARGET Grantlee_Templates PROPERTY EXPORT_NAME Templates)
+ target_include_directories(Grantlee_Templates PRIVATE ../scriptabletags)
++target_include_directories(Grantlee_Templates INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>")
+
+ if (BUILD_TESTS)
+ set(GRANTLEE_TESTS_EXPORT "GRANTLEE_TEMPLATES_EXPORT")
+diff --git a/textdocument/lib/CMakeLists.txt b/textdocument/lib/CMakeLists.txt
+index 14163db..7c609f9 100644
+--- a/textdocument/lib/CMakeLists.txt
++++ b/textdocument/lib/CMakeLists.txt
+@@ -24,7 +24,7 @@ add_library(Grantlee_TextDocument SHARED
+ generate_export_header(Grantlee_TextDocument)
+ add_library(Grantlee::TextDocument ALIAS Grantlee_TextDocument)
+ set_property(TARGET Grantlee_TextDocument PROPERTY EXPORT_NAME TextDocument)
+-
++target_include_directories(Grantlee_TextDocument INTERFACE "$<INSTALL_INTERFACE:${INCLUDE_INSTALL_DIR}>")
+
+ target_link_libraries(Grantlee_TextDocument
+ LINK_PUBLIC Qt5::Gui
diff --git a/dev-libs/grantlee/grantlee-0.4.0.ebuild b/dev-libs/grantlee/grantlee-0.4.0.ebuild
new file mode 100644
index 000000000000..a5a7e49e1afd
--- /dev/null
+++ b/dev-libs/grantlee/grantlee-0.4.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="C++ string template engine based on the Django template system"
+HOMEPAGE="http://www.gitorious.org/grantlee/pages/Home"
+SRC_URI="http://downloads.grantlee.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE="debug doc test"
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+"
+DEPEND="${RDEPEND}
+ doc? ( >=app-doc/doxygen-1.7.6.1[dot] )
+ test? ( dev-qt/qttest:4 )
+"
+
+# Some tests fail
+RESTRICT="test"
+
+DOCS=( AUTHORS CHANGELOG GOALS README )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_build test TESTS)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_compile docs
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${BUILD_DIR}/apidox/" )
+
+ cmake-utils_src_install
+}
diff --git a/dev-libs/grantlee/grantlee-5.0.0.ebuild b/dev-libs/grantlee/grantlee-5.0.0.ebuild
new file mode 100644
index 000000000000..2134e804594e
--- /dev/null
+++ b/dev-libs/grantlee/grantlee-5.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VIRTUALX_REQUIRED="test"
+inherit cmake-utils virtualx
+
+DESCRIPTION="C++ string template engine based on the Django template system"
+HOMEPAGE="http://www.gitorious.org/grantlee/pages/Home"
+SRC_URI="http://downloads.grantlee.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm"
+IUSE="debug doc test"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtscript:5
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ test? ( dev-qt/qttest:5 )
+"
+
+DOCS=( AUTHORS CHANGELOG README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.0-nonfatal-warnings.patch"
+ "${FILESDIR}/${PN}-slot.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ use doc && cmake-utils_src_compile docs
+}
+
+src_test() {
+ VIRTUALX_COMMAND="cmake-utils_src_test" virtualmake
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${BUILD_DIR}/apidox/")
+
+ cmake-utils_src_install
+}
diff --git a/dev-libs/grantlee/metadata.xml b/dev-libs/grantlee/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/dev-libs/grantlee/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>