summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGonçalo Negrier Duarte <gonegrier.duarte@gmail.com>2024-01-02 12:02:54 +0000
committerYixun Lan <dlan@gentoo.org>2024-01-03 13:30:27 +0000
commit99936763740d1db61ed0413edf83b7b98b9d345f (patch)
tree1694668fad6d2a379e86068840530db13d159390 /dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild
parentgui-apps/swappy: update live ebuild (diff)
downloadgentoo-99936763740d1db61ed0413edf83b7b98b9d345f.tar.gz
gentoo-99936763740d1db61ed0413edf83b7b98b9d345f.tar.bz2
gentoo-99936763740d1db61ed0413edf83b7b98b9d345f.zip
dev-libs/hyprland-protocols: add 9999 add 0.2-r1
Closes: https://github.com/gentoo/gentoo/pull/34603 Signed-off-by: Gonçalo Negrier Duarte <gonegrier.duarte@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild')
-rw-r--r--dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild b/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild
new file mode 100644
index 000000000000..0de43fcf06fb
--- /dev/null
+++ b/dev-libs/hyprland-protocols/hyprland-protocols-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol extensions for Hyprland"
+HOMEPAGE="https://github.com/hyprwm/hyprland-protocols"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hyprwm/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="amd64 ~riscv"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"