summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-25 23:55:35 +0000
committerSam James <sam@gentoo.org>2022-03-26 00:00:56 +0000
commitb7d492ff93212de55b9844dc6aabcef5493c69d5 (patch)
treeea4558a8cae76b0cd20ed3f226292b4930f2a89f /dev-libs/libaio
parentdev-embedded/avra: [QA] fix tc-get* quoting (diff)
downloadgentoo-b7d492ff93212de55b9844dc6aabcef5493c69d5.tar.gz
gentoo-b7d492ff93212de55b9844dc6aabcef5493c69d5.tar.bz2
gentoo-b7d492ff93212de55b9844dc6aabcef5493c69d5.zip
dev-libs/libaio: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libaio')
-rw-r--r--dev-libs/libaio/libaio-0.3.112.ebuild12
-rw-r--r--dev-libs/libaio/libaio-9999.ebuild12
2 files changed, 12 insertions, 12 deletions
diff --git a/dev-libs/libaio/libaio-0.3.112.ebuild b/dev-libs/libaio/libaio-0.3.112.ebuild
index a83b08bd9822..8c82444565a2 100644
--- a/dev-libs/libaio/libaio-0.3.112.ebuild
+++ b/dev-libs/libaio/libaio-0.3.112.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -46,17 +46,17 @@ multilib_src_configure() {
if use arm ; then
# When building for thumb, we can't allow frame pointers.
# http://crbug.com/464517
- if $(tc-getCPP) ${CFLAGS} ${CPPFLAGS} - <<<$'#ifndef __thumb__\n#error\n#endif' >&/dev/null ; then
+ if "$(tc-getCPP)" ${CFLAGS} ${CPPFLAGS} - <<<$'#ifndef __thumb__\n#error\n#endif' >&/dev/null ; then
append-flags -fomit-frame-pointer
fi
fi
}
_emake() {
- CC=$(tc-getCC) \
- AR=$(tc-getAR) \
- RANLIB=$(tc-getRANLIB) \
- ABI_LIBDIR=$(get_libdir) \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ ABI_LIBDIR="$(get_libdir)" \
CFLAGS_WERROR= \
emake "$@"
}
diff --git a/dev-libs/libaio/libaio-9999.ebuild b/dev-libs/libaio/libaio-9999.ebuild
index 232c53681871..87ca662c92c6 100644
--- a/dev-libs/libaio/libaio-9999.ebuild
+++ b/dev-libs/libaio/libaio-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -46,17 +46,17 @@ multilib_src_configure() {
if use arm ; then
# When building for thumb, we can't allow frame pointers.
# http://crbug.com/464517
- if $(tc-getCPP) ${CFLAGS} ${CPPFLAGS} - <<<$'#ifndef __thumb__\n#error\n#endif' >&/dev/null ; then
+ if "$(tc-getCPP)" ${CFLAGS} ${CPPFLAGS} - <<<$'#ifndef __thumb__\n#error\n#endif' >&/dev/null ; then
append-flags -fomit-frame-pointer
fi
fi
}
_emake() {
- CC=$(tc-getCC) \
- AR=$(tc-getAR) \
- RANLIB=$(tc-getRANLIB) \
- ABI_LIBDIR=$(get_libdir) \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ ABI_LIBDIR="$(get_libdir)" \
CFLAGS_WERROR= \
emake "$@"
}