summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-08-06 18:08:30 +0200
committerMichał Górny <mgorny@gentoo.org>2017-08-06 18:09:28 +0200
commitc9e18266ca78374d98ca3c1c24aed191764b53c1 (patch)
tree8aee6effb653151e747852e8b0f90dd75ba7f52f /dev-libs/libdbusmenu
parentwww-apps/wordpress: 4.8.1 (diff)
downloadgentoo-c9e18266ca78374d98ca3c1c24aed191764b53c1.tar.gz
gentoo-c9e18266ca78374d98ca3c1c24aed191764b53c1.tar.bz2
gentoo-c9e18266ca78374d98ca3c1c24aed191764b53c1.zip
dev-libs/libdbusmenu: Fix building w/ USE=-test
Diffstat (limited to 'dev-libs/libdbusmenu')
-rw-r--r--dev-libs/libdbusmenu/files/libdbusmenu-16.04.0-configure-fix.patch35
-rw-r--r--dev-libs/libdbusmenu/libdbusmenu-16.04.0.ebuild6
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-libs/libdbusmenu/files/libdbusmenu-16.04.0-configure-fix.patch b/dev-libs/libdbusmenu/files/libdbusmenu-16.04.0-configure-fix.patch
new file mode 100644
index 000000000000..a57877810904
--- /dev/null
+++ b/dev-libs/libdbusmenu/files/libdbusmenu-16.04.0-configure-fix.patch
@@ -0,0 +1,35 @@
+From 4b79b41a25cc1e2c4355738b4bed6c73b919ffee Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sun, 6 Aug 2017 17:55:45 +0200
+Subject: [PATCH] configure: Fix HAVE_VALGRIND not being defined when tests are
+ disabled
+
+If --disable-tests is used, configure fails with the following error:
+
+ configure: error: conditional "HAVE_VALGRIND" was never defined.
+ Usually this means the macro was only invoked conditionally.
+
+This is because AM_CONDITIONAL for it is called inside the 'if' for
+tests being enabled. Move it just below that block to ensure that it's
+defined unconditionally.
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index ace54d1..cbd38a6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -120,8 +120,8 @@ PKG_CHECK_MODULES(DBUSMENUTESTS, json-glib-1.0 >= $JSON_GLIB_REQUIRED_VERSION
+ [have_tests=yes]
+ )
+ PKG_CHECK_MODULES(DBUSMENUTESTSVALGRIND, valgrind, have_valgrind=yes, have_valgrind=no)
+-AM_CONDITIONAL([HAVE_VALGRIND], [test "x$have_valgrind" = "xyes"])
+ ])
++AM_CONDITIONAL([HAVE_VALGRIND], [test "x$have_valgrind" = "xyes"])
+
+ AC_SUBST(DBUSMENUTESTS_CFLAGS)
+ AC_SUBST(DBUSMENUTESTS_LIBS)
+--
+2.14.0
+
diff --git a/dev-libs/libdbusmenu/libdbusmenu-16.04.0.ebuild b/dev-libs/libdbusmenu/libdbusmenu-16.04.0.ebuild
index 5b4dc1f1df45..131d663ca800 100644
--- a/dev-libs/libdbusmenu/libdbusmenu-16.04.0.ebuild
+++ b/dev-libs/libdbusmenu/libdbusmenu-16.04.0.ebuild
@@ -8,8 +8,8 @@ VALA_USE_DEPEND=vapigen
PYTHON_COMPAT=( python2_7 )
VIRTUALX_REQUIRED=manual
-inherit flag-o-matic multilib-minimal python-single-r1 vala virtualx \
- xdg-utils
+inherit autotools flag-o-matic multilib-minimal python-single-r1 vala \
+ virtualx xdg-utils
DESCRIPTION="Library to pass menu structure across DBus"
HOMEPAGE="https://launchpad.net/dbusmenu"
@@ -57,7 +57,9 @@ src_prepare() {
fi
python_fix_shebang tools
+ eapply "${FILESDIR}/${P}-configure-fix.patch"
eapply_user
+ eautoreconf
}
multilib_src_configure() {