summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-08-28 09:59:43 -0400
committerCraig Andrews <candrews@gentoo.org>2023-08-28 10:04:50 -0400
commit7657efd4381fda4e9ccbca2d4db99c8aa694e88c (patch)
treecb7f54b79f13a29421b3c0f9b032ece968b34b9b /dev-libs/libfmt/libfmt-10.1.1.ebuild
parentprofiles/arch/hppa: mask >=dev-libs/libuv-1.45.0 (diff)
downloadgentoo-7657efd4381fda4e9ccbca2d4db99c8aa694e88c.tar.gz
gentoo-7657efd4381fda4e9ccbca2d4db99c8aa694e88c.tar.bz2
gentoo-7657efd4381fda4e9ccbca2d4db99c8aa694e88c.zip
dev-libs/libfmt: add 10.1.1
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-libs/libfmt/libfmt-10.1.1.ebuild')
-rw-r--r--dev-libs/libfmt/libfmt-10.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libfmt/libfmt-10.1.1.ebuild b/dev-libs/libfmt/libfmt-10.1.1.ebuild
new file mode 100644
index 000000000000..90083087d20e
--- /dev/null
+++ b/dev-libs/libfmt/libfmt-10.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Small, safe and fast formatting library"
+HOMEPAGE="https://github.com/fmtlib/fmt"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/fmtlib/fmt.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fmtlib/fmt/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+ S="${WORKDIR}/fmt-${PV}"
+fi
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DFMT_CMAKE_DIR="$(get_libdir)/cmake/fmt"
+ -DFMT_LIB_DIR="$(get_libdir)"
+ -DFMT_TEST=$(usex test)
+ )
+ cmake_src_configure
+}