summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-23 02:31:34 +0100
committerSam James <sam@gentoo.org>2024-06-23 02:49:02 +0100
commitc5a4e52336f1f1c449e3482b1344df7dccb0e05f (patch)
treed4ee651f68a7217f979adf39d6a946808598d6ce /dev-libs/libgpg-error
parentdev-libs/libassuan: add 3.0.0 (diff)
downloadgentoo-c5a4e52336f1f1c449e3482b1344df7dccb0e05f.tar.gz
gentoo-c5a4e52336f1f1c449e3482b1344df7dccb0e05f.tar.bz2
gentoo-c5a4e52336f1f1c449e3482b1344df7dccb0e05f.zip
dev-libs/libgpg-error: add 1.50
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libgpg-error')
-rw-r--r--dev-libs/libgpg-error/Manifest2
-rw-r--r--dev-libs/libgpg-error/files/libgpg-error-1.50-environ.patch31
-rw-r--r--dev-libs/libgpg-error/libgpg-error-1.50.ebuild92
3 files changed, 125 insertions, 0 deletions
diff --git a/dev-libs/libgpg-error/Manifest b/dev-libs/libgpg-error/Manifest
index 5c24aeb0ee7e..f9d1b2b50d10 100644
--- a/dev-libs/libgpg-error/Manifest
+++ b/dev-libs/libgpg-error/Manifest
@@ -4,3 +4,5 @@ DIST libgpg-error-1.48.tar.bz2 1080417 BLAKE2B 4ced63058586558f4d001bcc468f4bd41
DIST libgpg-error-1.48.tar.bz2.sig 119 BLAKE2B 36e74c520df1740d48630584cb7093413c7974157038dd0e732cb821d6e3b3386a331be9e94a7f19ea10256bd2902d778d52fe1eeab68065ef9dc2625ac2902c SHA512 302091beddab877acf4355f913fae4bd0a795f0a032f47e0e17c58fe1049833116a743d3470669cff59eab2f6d184b143689763cbb4d0f2f9bcab598e09dc12c
DIST libgpg-error-1.49.tar.bz2 1081175 BLAKE2B f1d7ce3c8b32a1a98495576b4ed7bf938b847a84d0fa3ed585d461ad6b136cf87112055a39b4859301f87f555666d9dbf0dda5ec03ea6270802d98352224071e SHA512 bb4dd3faa8e2ec945e61fb2006697b48a51da7ee510b6650a6ab09c8734a987bc33c9835bc710ca9a9395c088271939091be418efc6ca5130b426c2fbc4959a3
DIST libgpg-error-1.49.tar.bz2.sig 119 BLAKE2B 6d290318fc8759b6c8bf09a2e2622ed645dded003ffdd76b599cd3ec8af3ca51abf237e35c0c942d78c72e95f6cd644df7eb63fabd8b69b9566bb4f878648f14 SHA512 7f36f603dbb492c4dcafe3eae153b35fede29bf85f50d8908c517330003babd8e357aa54e3f354cd0abbcb9862435d5756ac85aff3c2968ce9fcde8cbf6565de
+DIST libgpg-error-1.50.tar.bz2 1082003 BLAKE2B 621d9a604585daa1fbd08aaa94f3b177f6265046ccf452317e126e73079c567c555cbb8ab8b63e09b76bdf4f11a1aad7effd118651fe9e9cbcf01229f20ab297 SHA512 96e466d892a50843af6d7c08c0da602518bc6a28836bfc35f0a28cde74d368f57c5c70c65f0f41edb4fc1ca5ebd00f2ece531d8b3eb1bd6db566adbb29bc61ff
+DIST libgpg-error-1.50.tar.bz2.sig 119 BLAKE2B ee3a8e9221d4df8b37ceef70240ecf79efef045cfbde67f6a8bbc0f58dfa4955ed5a75e3cd31de7644707049919b154c1d9607e370dec7e8f2b0b6cb1b997beb SHA512 02e29838be3225f4894bcebd2c53355a98f5857baa4e9f8a78227a03f849677c35b1d2d009610badd6540dcfe5378b5365abcae77d29ba2d95dd252e9c93c893
diff --git a/dev-libs/libgpg-error/files/libgpg-error-1.50-environ.patch b/dev-libs/libgpg-error/files/libgpg-error-1.50-environ.patch
new file mode 100644
index 000000000000..761e884aa806
--- /dev/null
+++ b/dev-libs/libgpg-error/files/libgpg-error-1.50-environ.patch
@@ -0,0 +1,31 @@
+https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgpg-error.git;a=commit;h=a59e902b887fd92337c9728f668cf9c89da3957a
+
+From a59e902b887fd92337c9728f668cf9c89da3957a Mon Sep 17 00:00:00 2001
+From: Werner Koch <wk@gnupg.org>
+Date: Thu, 20 Jun 2024 12:05:15 +0200
+Subject: [PATCH] core: Declare environ for macOS and others.
+
+* src/spawn-posix.c (environ): Declare.
+--
+
+GnuPG-bug-id: 7169
+---
+ src/spawn-posix.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/spawn-posix.c b/src/spawn-posix.c
+index 7de02a9..96f1536 100644
+--- a/src/spawn-posix.c
++++ b/src/spawn-posix.c
+@@ -57,6 +57,9 @@
+
+ #include "gpgrt-int.h"
+
++/* (Only glibc's unistd.h declares this iff _GNU_SOURCE is used.) */
++extern char **environ;
++
+
+ /* Definition for the gpgrt_spawn_actions_t. Note that there is a
+ * different one for Windows. */
+--
+2.30.2
diff --git a/dev-libs/libgpg-error/libgpg-error-1.50.ebuild b/dev-libs/libgpg-error/libgpg-error-1.50.ebuild
new file mode 100644
index 000000000000..a2ccb520f561
--- /dev/null
+++ b/dev-libs/libgpg-error/libgpg-error-1.50.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Maintainers should:
+# 1. Join the "Gentoo" project at https://dev.gnupg.org/project/view/27/
+# 2. Subscribe to release tasks like https://dev.gnupg.org/T6159
+# (find the one for the current release then subscribe to it +
+# any subsequent ones linked within so you're covered for a while.)
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/gnupg.asc
+inherit multilib-minimal toolchain-funcs verify-sig
+
+DESCRIPTION="Contains error handling functions used by GnuPG software"
+HOMEPAGE="https://www.gnupg.org/related_software/libgpg-error"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnupg/${PN}/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="common-lisp nls static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="nls? ( >=virtual/libintl-0-r1[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ verify-sig? ( sec-keys/openpgp-keys-gnupg )
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/gpg-error.h
+ /usr/include/gpgrt.h
+)
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/gpg-error-config
+ /usr/bin/gpgrt-config
+)
+
+PATCHES=(
+ "${FILESDIR}"/${P}-environ.patch
+)
+
+src_prepare() {
+ default
+
+ if use prefix ; then
+ # don't hardcode /usr/xpg4/bin/sh as shell on Solaris
+ sed -i -e 's:INSTALLSHELLPATH=/usr/xpg4/bin/sh:INSTALLSHELLPATH=/bin/sh:g' configure.ac configure || die
+ fi
+
+ # This check breaks multilib
+ cat <<-EOF > src/gpg-error-config-test.sh.in || die
+ #!@INSTALLSHELLPATH@
+ exit 0
+ EOF
+
+ # only necessary for as long as we run eautoreconf, configure.ac
+ # uses ./autogen.sh to generate PACKAGE_VERSION, but autogen.sh is
+ # not a pure /bin/sh script, so it fails on some hosts
+ #sed -i -e "1s:.*:#\!${BASH}:" autogen.sh || die
+ #eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ $(multilib_is_native_abi || echo --disable-languages)
+ $(use_enable common-lisp languages)
+ $(use_enable nls)
+ # required for sys-power/suspend[crypt], bug 751568
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+
+ # See bug #699206 and its duplicates wrt gpgme-config
+ # Upstream no longer install this by default and we should
+ # seek to disable it at some point.
+ --enable-install-gpg-error-config
+
+ --enable-threads
+ CC_FOR_BUILD="$(tc-getBUILD_CC)"
+ $("${S}/configure" --help | grep -o -- '--without-.*-prefix')
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name '*.la' -delete || die
+}