summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-22 05:41:30 +0000
committerSam James <sam@gentoo.org>2021-02-22 07:23:55 +0000
commit1cf62b5cda2f53a3a8d9e218db5b2a7ffd2b4158 (patch)
treea58f068e9f4db90d4d04c6c9a5762c2a7729a6d3 /dev-libs/libmaxminddb
parentdev-tex/latex-beamer: bump to 3.61 (diff)
downloadgentoo-1cf62b5cda2f53a3a8d9e218db5b2a7ffd2b4158.tar.gz
gentoo-1cf62b5cda2f53a3a8d9e218db5b2a7ffd2b4158.tar.bz2
gentoo-1cf62b5cda2f53a3a8d9e218db5b2a7ffd2b4158.zip
dev-libs/libmaxminddb: (security) bump to 1.5.2
Bug: https://bugs.gentoo.org/771354 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libmaxminddb')
-rw-r--r--dev-libs/libmaxminddb/Manifest1
-rw-r--r--dev-libs/libmaxminddb/libmaxminddb-1.5.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libmaxminddb/Manifest b/dev-libs/libmaxminddb/Manifest
index 099eafa997e6..04b237f232e4 100644
--- a/dev-libs/libmaxminddb/Manifest
+++ b/dev-libs/libmaxminddb/Manifest
@@ -1,2 +1,3 @@
DIST libmaxminddb-1.4.3.tar.gz 602272 BLAKE2B 2974d7268201a906c1c478ee36d4ef61e5f7483fd4f91bfcc5bf92f5bc698e8dd9eef256cceeb8c3217054481827d6fbf075f479e76c6506cc1f31d707a7d9dd SHA512 7fd97678ea6ca41cc4530864276b0233acbb16208571dc4694902943b3aa7e97c683c5676ea3f2de948c67aebd083f5d073b9ae36b7e89059c17f797ffddf65e
DIST libmaxminddb-1.5.0.tar.gz 603923 BLAKE2B 07c18f759a2d437d95be513d6dc3aaddd5dcd6f7201fdd7eba0f035c5a3221344f1e5e44253c0efdc2690cfffc5cecdaa9befed8d69f6f0ebd33588b3805443d SHA512 68c769f247156869b84a8ad0f9deec3cb79d39c0a6b8f1458461c223b9cf9967dd9d697ff4e92ac28216ef9e9f5a94908e03f76a5f70ab17636b163c17d2d432
+DIST libmaxminddb-1.5.2.tar.gz 604683 BLAKE2B 4dea7413be59169104adf3dc5dfe3e4f3bdb4639bbb4a0c6365d93216e279d505f01e32f737bf66d9f5b98f65f3eaefa46f630458bd6032a32be8c74acf12a1b SHA512 074ef6b62a74cede7be332eaeff5aa7442f43de92d39ea65b38430f0e1b65a5515f4343894ca5c28a7d50181eaec44e8db7083461b9e12e7014d2d1e0ff033b8
diff --git a/dev-libs/libmaxminddb/libmaxminddb-1.5.2.ebuild b/dev-libs/libmaxminddb/libmaxminddb-1.5.2.ebuild
new file mode 100644
index 000000000000..c0672dead589
--- /dev/null
+++ b/dev-libs/libmaxminddb/libmaxminddb-1.5.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="C library for the MaxMind DB file format"
+HOMEPAGE="https://github.com/maxmind/libmaxminddb"
+SRC_URI="https://github.com/maxmind/libmaxminddb/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/0.0.7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="test? ( dev-perl/IPC-Run3 )"
+
+DOCS=( Changes.md )
+
+src_configure() {
+ econf --disable-static
+ tc-export AR CC
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}