summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-04 23:21:55 +0100
committerSam James <sam@gentoo.org>2022-09-04 23:56:38 +0100
commite2f45f79f593e512eb6da5ffdeced0b6bcfdd08b (patch)
tree728e1d368ba28a2d9f40383b22fd7760cabce166 /dev-libs/libofx
parentsys-apps/gawk: add 5.2.0, drop 5.1.65 (diff)
downloadgentoo-e2f45f79f593e512eb6da5ffdeced0b6bcfdd08b.tar.gz
gentoo-e2f45f79f593e512eb6da5ffdeced0b6bcfdd08b.tar.bz2
gentoo-e2f45f79f593e512eb6da5ffdeced0b6bcfdd08b.zip
dev-libs/libofx: add 0.10.6
Not porting to CMake yet as this is the first release with it and there's some fixes we need to land upstream first. (And it lacks tests + docs for now.) Bug: https://github.com/libofx/libofx/pull/73 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libofx')
-rw-r--r--dev-libs/libofx/Manifest1
-rw-r--r--dev-libs/libofx/libofx-0.10.6.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libofx/Manifest b/dev-libs/libofx/Manifest
index ca4371e0ffd4..bd8bd434efdf 100644
--- a/dev-libs/libofx/Manifest
+++ b/dev-libs/libofx/Manifest
@@ -1 +1,2 @@
DIST libofx-0.10.3.tar.gz 225132 BLAKE2B 29dff4cb79a4a535bf255c787e184d103ecdbe975bb4bb223b675bbacaff9f8a228ae0a3dffe7710c2707496ac65c4f48ce993243b8353172c53cb02067d9267 SHA512 6c024628a6a11d9542c669a438223331a033eb820b1a2c3001c60d1ab3fad45ccdec64f9b54dd206fe0058ead8e14e751eb7a3bd88e8f9e1013b0bdd5b6c5242
+DIST libofx-0.10.6.tar.gz 1836880 BLAKE2B 4c5fd24576f969e9ced311e112f183596905bd1225dbfe8646a8f24d545d49fe3b496baadf46e174bfb708ffbaac67b44e746cc8acb8e74509ef5ec22f8f3972 SHA512 8c8a569ca3083c7101c051857d286c3615461fdd88065666d7d6dc53a95d1251a6e5fd44be6cbf54e3591d9ba2b3916c846a4e9e83d6a6c4724e35a193c6a679
diff --git a/dev-libs/libofx/libofx-0.10.6.ebuild b/dev-libs/libofx/libofx-0.10.6.ebuild
new file mode 100644
index 000000000000..87cfdff2482d
--- /dev/null
+++ b/dev-libs/libofx/libofx-0.10.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Library to support the Open Financial eXchange XML format"
+HOMEPAGE="https://github.com/libofx/libofx"
+SRC_URI="https://github.com/libofx/libofx/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/10"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-util/gengetopt
+ sys-apps/help2man
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( app-crypt/gnupg )
+"
+RDEPEND="
+ >app-text/opensp-1.5
+ app-text/openjade
+ >=dev-cpp/libxmlpp-2.40.1:2.6
+ >=net-misc/curl-7.9.7
+ virtual/libiconv
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # bug #566456
+ append-cxxflags -std=c++14
+
+ econf $(use_enable doc html-docs)
+}
+
+src_compile() {
+ emake all $(usev doc)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -type f -delete || die
+ find "${ED}" -name '*.a' -type f -delete || die
+}