summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2016-09-05 12:55:37 +0300
committerSergey Popov <pinkbyte@gentoo.org>2016-09-05 12:58:43 +0300
commit59f48475a80300b59c8daaa089d3968573a04b5e (patch)
tree78edb8c0b70d1ea0c9e8296f00e34260fcb545f3 /dev-libs/libsqlora8
parentdev-python/vcstools: bump to 0.1.39 (diff)
downloadgentoo-59f48475a80300b59c8daaa089d3968573a04b5e.tar.gz
gentoo-59f48475a80300b59c8daaa089d3968573a04b5e.tar.bz2
gentoo-59f48475a80300b59c8daaa089d3968573a04b5e.zip
dev-libs/libsqlora8: revision bump
Bump EAPI to 6. Supress unsupported parallel compilation, prune unneeded libtool files, build static libs optionally, correct package description. Detect Oracle libraries path, rather than requesting it from user. Replace misused einstall with default function call in src_install. Gentoo-Bug: 521432 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/libsqlora8')
-rw-r--r--dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild56
-rw-r--r--dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild61
2 files changed, 56 insertions, 61 deletions
diff --git a/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild b/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild
new file mode 100644
index 000000000000..8f15319b285a
--- /dev/null
+++ b/dev-libs/libsqlora8/libsqlora8-2.3.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils flag-o-matic versionator
+
+DESCRIPTION="Simple C-library to access Oracle databases via the OCI interface"
+SRC_URI="http://www.poitschke.de/libsqlora8/${P}.tar.gz"
+HOMEPAGE="http://www.poitschke.de/libsqlora8/index_noframe.html"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE="orathreads static-libs +threads"
+
+RDEPEND="dev-db/oracle-instantclient"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="?? ( orathreads threads )"
+
+src_configure() {
+ local myconf
+
+ local ORACLE_VER="$(best_version dev-db/oracle-instantclient)"
+ ORACLE_VER="${ORACLE_VER#*/*-*-}" #reduce it to ${PV}-${PR}
+ ORACLE_VER="$(get_version_component_range 1-2 ${ORACLE_VER})"
+ append-ldflags -L"/usr/lib/oracle/${ORACLE_VER}/client/lib"
+
+ use threads && myconf="--with-threads=posix"
+ use orathreads && myconf="--with-threads=oracle"
+
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_compile() {
+ # Parallel compilation is not supported
+ emake -j1
+}
+
+src_install () {
+ default
+ prune_libtool_files
+ dodoc ChangeLog NEWS NEWS-2.2
+
+ # TODO
+ # Copy contents of doc and examples directory to proper place
+ rm -r "${D}/usr/share/doc/packages"
+}
diff --git a/dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild b/dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild
deleted file mode 100644
index c7a509beee78..000000000000
--- a/dev-libs/libsqlora8/libsqlora8-2.3.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-DESCRIPTION="libsqlora8 is a simple C-library to access Oracle databases via the OCI interface"
-SRC_URI="http://www.poitschke.de/libsqlora8/${P}.tar.gz"
-HOMEPAGE="http://www.poitschke.de/libsqlora8/index_noframe.html"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="threads orathreads"
-
-DEPEND=""
-
-pkg_setup() {
- if use orathreads && use threads; then
- eerror
- eerror 'Enable the "threads" USE flag for POSIX threads,'
- eerror '*or* the "orathreads" USE flag for Oracle threads'
- eerror
- die 'Both "threads" and "orathreads" USE flags set, see above'
- fi
-
- # Make sure ORACLE_HOME is set
- if [ -z "${ORACLE_HOME}" ]; then
- eerror
- eerror 'libsqlora8 requires that the ORACLE_HOME environment variable be set.'
- eerror 'Try: "export ORACLE_HOME=/usr/local/oracle" if you do not know what to do.'
- eerror
- die 'ORACLE_HOME not set, see above'
- fi
-}
-
-src_compile() {
- local myconf;
-
- # Add $ORACLE_HOME/lib to LD_LIBRARY_PATH
- if [ -z "${LD_LIBRARY_PATH}" ]; then
- LD_LIBRARY_PATH=${ORACLE_HOME}/lib
- else
- LD_LIBRARY_PATH=${ORACLE_HOME}/lib:${LD_LIBRARY_PATH}
- fi
-
- export LD_LIBRARY_PATH
-
- use threads && myconf="--with-threads=posix"
- use orathreads && myconf="--with-threads=oracle"
-
- # Build
- econf ${myconf} || die "configure failed"
- emake
-}
-
-src_install () {
- einstall
- dodoc ChangeLog NEWS NEWS-2.2
-
- # TODO
- # Copy contents of doc and examples directory to doc
-}