summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-29 19:51:08 +0100
committerSam James <sam@gentoo.org>2022-08-29 19:56:03 +0100
commit77ae592c410a8257d4f598ebe769989efe075e42 (patch)
treeb6b58bb284f17ee945192da1dbebf2c50eacd1cc /dev-libs/libxslt
parentdev-libs/libxslt: add 1.1.37 (diff)
downloadgentoo-77ae592c410a8257d4f598ebe769989efe075e42.tar.gz
gentoo-77ae592c410a8257d4f598ebe769989efe075e42.tar.bz2
gentoo-77ae592c410a8257d4f598ebe769989efe075e42.zip
dev-libs/libxslt: drop 1.1.36
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/libxslt')
-rw-r--r--dev-libs/libxslt/Manifest1
-rw-r--r--dev-libs/libxslt/libxslt-1.1.36.ebuild124
2 files changed, 0 insertions, 125 deletions
diff --git a/dev-libs/libxslt/Manifest b/dev-libs/libxslt/Manifest
index f244ecce79d0..2dfb0498704b 100644
--- a/dev-libs/libxslt/Manifest
+++ b/dev-libs/libxslt/Manifest
@@ -1,3 +1,2 @@
DIST libxslt-1.1.35.tar.xz 1827548 BLAKE2B 9667a93e61f50098a512c1351bce2ee937fc5d29488d010b525122d28ffedc73e0930402f3df2d378161a031dc016a15f0f03bdc343f0c4aa5d0b5c454f8002d SHA512 9dd4a699235f50ae9b75b25137e387471635b4b2da0a4e4380879cd49f1513470fcfbfd775269b066eac513a1ffa6860c77ec42747168e2348248f09f60c8c96
-DIST libxslt-1.1.36.tar.xz 1591356 BLAKE2B 7cdb38b52295477dcf4c9fdecfb64bc8e770b37787b3f4522d6156838725f4ee506b6d58ec18d17adeb22c78aa62d0685e77ad23e72901d1083de4efef1ae0df SHA512 8a524d32fca18e8b108c1b300d1381c01a71a87dc72a09bc13613772c2836b1350d8caa0625782c6cadf953f7a15ce805718a754cef894ee77b20442fc10f5c8
DIST libxslt-1.1.37.tar.xz 1588572 BLAKE2B 096d93dd7178bf4483207514b1435f5bf426eea4952ffab7cc00c3e85aa736534c4acb5377af9647aa77a0cd793205194509d997a7bb5cae692f65e326566cd8 SHA512 a4e477d2bb918b7d01945e2c7491c3a4aae799dc1602bbd13de55c8a5052e210a20bc45115347eae44473c8b1d03dbc5e4a2aa18c2218f1fdfd376d87cd501ca
diff --git a/dev-libs/libxslt/libxslt-1.1.36.ebuild b/dev-libs/libxslt/libxslt-1.1.36.ebuild
deleted file mode 100644
index 6f198ac22606..000000000000
--- a/dev-libs/libxslt/libxslt-1.1.36.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Note: Please bump this in sync with dev-libs/libxml2.
-
-PYTHON_COMPAT=( python3_{8..11} )
-inherit autotools python-r1 multilib-minimal
-
-DESCRIPTION="XSLT libraries and tools"
-HOMEPAGE="https://gitlab.gnome.org/GNOME/libxslt"
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/libxslt"
- inherit git-r3
-else
- inherit gnome.org
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="crypt debug examples python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-BDEPEND=">=virtual/pkgconfig-1"
-RDEPEND="
- >=dev-libs/libxml2-2.9.11:2[${MULTILIB_USEDEP}]
- crypt? ( >=dev-libs/libgcrypt-1.5.3:0=[${MULTILIB_USEDEP}] )
- python? ( ${PYTHON_DEPS} )
-"
-DEPEND="${RDEPEND}"
-
-MULTILIB_CHOST_TOOLS=(
- /usr/bin/xslt-config
-)
-
-MULTILIB_WRAPPED_HEADERS=(
- /usr/include/libxslt/xsltconfig.h
-)
-
-DOCS=( AUTHORS FEATURES NEWS README TODO )
-
-src_prepare() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- eautoreconf
- else
- # Prefix always needs elibtoolize if not eautoreconf'd.
- #elibtoolize
-
- # Temporarily for Python 3.10 fix (version used for
- # dist tarballs fails w/ "3.1" error)
- # See https://gitlab.gnome.org/GNOME/libxslt/-/issues/72.
- eautoreconf
- fi
-}
-
-multilib_src_configure() {
- libxslt_configure() {
- ECONF_SOURCE="${S}" econf \
- --without-python \
- $(use_with crypt crypto) \
- $(use_with debug) \
- $(use_with debug mem-debug) \
- $(use_enable static-libs static) \
- "$@"
- }
-
- # Build Python bindings separately
- libxslt_configure --without-python
-
- if multilib_is_native_abi && use python ; then
- NATIVE_BUILD_DIR="${BUILD_DIR}"
- python_foreach_impl run_in_build_dir libxslt_configure --with-python
- fi
-}
-
-libxslt_py_emake() {
- pushd "${BUILD_DIR}"/python >/dev/null || die
-
- emake top_builddir="${NATIVE_BUILD_DIR}" "$@"
-
- popd >/dev/null || die
-}
-
-multilib_src_compile() {
- default
-
- if multilib_is_native_abi && use python ; then
- python_foreach_impl run_in_build_dir libxslt_py_emake all
- fi
-}
-
-multilib_src_test() {
- default
-
- if multilib_is_native_abi && use python ; then
- python_foreach_impl run_in_build_dir libxslt_py_emake test
- fi
-}
-
-multilib_src_install() {
- # "default" does not work here - docs are installed by multilib_src_install_all
- emake DESTDIR="${D}" install
-
- if multilib_is_native_abi && use python; then
- python_foreach_impl run_in_build_dir libxslt_py_emake \
- DESTDIR="${D}" \
- install
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if ! use examples ; then
- rm -rf "${ED}"/usr/share/doc/${PF}/tutorial{,2} || die
- rm -rf "${ED}"/usr/share/doc/${PF}/python/examples || die
- fi
-
- find "${ED}" -type f -name "*.la" -delete || die
-}