summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-02 18:19:25 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-02 18:19:25 +0200
commit2195a8deaa56637ab767ea7d95f3cfa83df9ef35 (patch)
tree2892aa41c966c7b8f813044907fa0ae1beaaac6e /dev-libs/ossp-uuid
parentnet-firewall/psad: update EAPI 6 -> 8 (diff)
downloadgentoo-2195a8deaa56637ab767ea7d95f3cfa83df9ef35.tar.gz
gentoo-2195a8deaa56637ab767ea7d95f3cfa83df9ef35.tar.bz2
gentoo-2195a8deaa56637ab767ea7d95f3cfa83df9ef35.zip
dev-libs/ossp-uuid: [QA] cleanups
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/ossp-uuid')
-rw-r--r--dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
index 335448aba2c5..33616b0f8acd 100644
--- a/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
+++ b/dev-libs/ossp-uuid/ossp-uuid-1.6.2-r7.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
MY_P="uuid-${PV}"
@@ -18,11 +18,15 @@ LICENSE="ISC"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE="+cxx perl static-libs test"
+RESTRICT="!test? ( test )"
-DEPEND="perl? ( dev-lang/perl test? ( virtual/perl-Test-Simple ) )"
+DEPEND="
+ perl? (
+ dev-lang/perl
+ test? ( virtual/perl-Test-Simple )
+ )"
RDEPEND="perl? ( dev-lang/perl:= )"
BDEPEND="perl? ( dev-lang/perl )"
-RESTRICT="!test? ( test )"
PATCHES=(
"${FILESDIR}/${P}-gentoo-r1.patch"
@@ -67,18 +71,17 @@ src_test() {
}
src_install() {
- local DOCS=( AUTHORS BINDINGS ChangeLog HISTORY NEWS OVERVIEW PORTING README SEEALSO THANKS TODO USERS )
default
- unset DOCS #unset so that other eclasses don't try to install them and possibly fail
+ dodoc BINDINGS HISTORY OVERVIEW PORTING SEEALSO USERS
if use perl ; then
cd perl || die
perl-module_src_install
fi
- use static-libs || rm -rf "${ED}"/usr/lib*/*.la
+ find "${ED}" -name '*.la' -delete || die
- mv "${ED}/usr/$(get_libdir)/pkgconfig"/{,ossp-}uuid.pc
- mv "${ED}/usr/share/man/man3"/uuid.3{,ossp}
- mv "${ED}/usr/share/man/man3"/uuid++.3{,ossp}
+ mv "${ED}"/usr/$(get_libdir)/pkgconfig/{,ossp-}uuid.pc || die
+ mv "${ED}"/usr/share/man/man3/uuid.3{,ossp} || die
+ mv "${ED}"/usr/share/man/man3/uuid++.3{,ossp} || die
}