summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2024-04-01 09:34:13 +0300
committerJoonas Niilola <juippis@gentoo.org>2024-04-01 09:47:33 +0300
commite786383d3ec41a865340287974adf4a70fc2b5aa (patch)
treecf20091a09272ec1384b9c8923c50cb549f02fc8 /dev-libs/raft
parentdev-util/cucumber-messages: add 24.1.0 (diff)
downloadgentoo-e786383d3ec41a865340287974adf4a70fc2b5aa.tar.gz
gentoo-e786383d3ec41a865340287974adf4a70fc2b5aa.tar.bz2
gentoo-e786383d3ec41a865340287974adf4a70fc2b5aa.zip
dev-libs/raft: add 0.22.1
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/raft')
-rw-r--r--dev-libs/raft/Manifest1
-rw-r--r--dev-libs/raft/raft-0.22.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/raft/Manifest b/dev-libs/raft/Manifest
index dc76a4688a6c..3db5f5aa8fc8 100644
--- a/dev-libs/raft/Manifest
+++ b/dev-libs/raft/Manifest
@@ -1,2 +1,3 @@
DIST raft-0.19.1.tar.gz 354736 BLAKE2B cfdb9a1948311debe99b56e0f9c1f19fb858248ab1138648e26a21d965cc488aea504711415ff569d2e80a15414a1f15ca9b34ff9b3de62b03580755cefe30b3 SHA512 4990dca1f61dcda82acaf043a5b81dd9a3b92a0f3e0be9b2c339d764be338220f2fab31ed8bae535153b1d81c86364d447774b52da2c8b90c5daa7b8718d7ae2
DIST raft-0.22.0.tar.gz 365710 BLAKE2B b5084867ebd7e80f59edebcf5feb83cc7ffbf798deecbf96d3b31c0de7213c8fc1e3e5f558602f5864fb04f8de0326ee2f70d2f6164a08dd444a8db95593c328 SHA512 0ebda5764c866443ee2749c0c8fe798f111ed500b9d59bc9536d01e01ee82a8ed72125fb02e6a0c3bf51e4004520d4c5fdb583220599cb22bb9a8e6dd9d1a54b
+DIST raft-0.22.1.tar.gz 362393 BLAKE2B b6fc8f8e9dc6801ac8ad1b9d94f984b249b83def00a08776292500b079bb777330e8a83cf40153bfb1baae921105788d758c9f61a021d5519d5c27048b6be8b9 SHA512 fb4ea98321336daaa605e1c3cd55f672860fc8894d479fdff4e1862a4eb5622dbaf7a943e030dd2bcdaa14cc639e7e11ac43d71f00bdbd27f12c6b67653b70e4
diff --git a/dev-libs/raft/raft-0.22.1.ebuild b/dev-libs/raft/raft-0.22.1.ebuild
new file mode 100644
index 000000000000..4b51fe639271
--- /dev/null
+++ b/dev-libs/raft/raft-0.22.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/cowsql/raft"
+SRC_URI="https://github.com/cowsql/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+
+# Upstream change from canonical to cowsql resetted SONAME, 3 -> 0. bgo#915960
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="lz4 test zfs"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv:=
+ lz4? ( app-arch/lz4:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # --disable-hardening: most of these are covered on non-hardened Gentoo already.
+ local myeconfargs=(
+ --enable-uv
+ --enable-v0
+
+ --disable-backtrace
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-hardening
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable test fixture)
+
+ $(use_with lz4)
+ $(use_with zfs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}