summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-08-13 01:36:31 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-08-13 01:43:10 +1000
commit10b59d39749196a759fd300365fbe565f584a554 (patch)
tree9581ec21baf6d92823d94e855469fbfcf912d02e /dev-libs
parentwww-servers/nginx: Bump to v1.13.4 mainline (diff)
downloadgentoo-10b59d39749196a759fd300365fbe565f584a554.tar.gz
gentoo-10b59d39749196a759fd300365fbe565f584a554.tar.bz2
gentoo-10b59d39749196a759fd300365fbe565f584a554.zip
dev-libs/qoauth: fix prf file to point to the correct header location
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/qoauth/files/qoauth-2.0.1_pre20160315-prf.patch15
-rw-r--r--dev-libs/qoauth/qoauth-2.0.1_pre20160315-r2.ebuild63
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-libs/qoauth/files/qoauth-2.0.1_pre20160315-prf.patch b/dev-libs/qoauth/files/qoauth-2.0.1_pre20160315-prf.patch
new file mode 100644
index 000000000000..c3457b0dba41
--- /dev/null
+++ b/dev-libs/qoauth/files/qoauth-2.0.1_pre20160315-prf.patch
@@ -0,0 +1,15 @@
+Point to where the headers are really installed.
+
+--- a/oauth.prf
++++ b/oauth.prf
+@@ -1,9 +1,6 @@
+-QOAUTH_INCDIR = $$[QT_INSTALL_HEADERS]
++QOAUTH_INCDIR = $$[QT_INSTALL_HEADERS]/..
+ QOAUTH_LIBDIR = $$[QT_INSTALL_LIBS]
+
+-QOAUTH_INCDIR ~= s!/qt4*!!
+-QOAUTH_LIBDIR ~= s!/qt4*!!
+-
+ CONFIG *= qt
+ CONFIG += crypto
+
diff --git a/dev-libs/qoauth/qoauth-2.0.1_pre20160315-r2.ebuild b/dev-libs/qoauth/qoauth-2.0.1_pre20160315-r2.ebuild
new file mode 100644
index 000000000000..5a5d7c526e5d
--- /dev/null
+++ b/dev-libs/qoauth/qoauth-2.0.1_pre20160315-r2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Qt-based library for OAuth support"
+HOMEPAGE="https://wiki.github.com/ayoy/qoauth"
+SRC_URI="https://dev.gentoo.org/~johu/distfiles/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug doc test"
+
+COMMON_DEPEND="
+ app-crypt/qca:2[debug?,qt5]
+ dev-qt/qtnetwork:5
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+ test? ( dev-qt/qttest:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ app-crypt/qca:2[ssl]
+ !dev-libs/qoauth:0
+"
+
+# disable functional tests that require network connection
+# and rely on 3rd party external server (bug #341267)
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.1-disable-ft.patch"
+ "${FILESDIR}/${P}-prf.patch"
+)
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e '/SUBDIRS/s/tests//' ${PN}.pro || die "sed failed"
+ fi
+
+ sed -i -e '/^ *docs \\$/d' \
+ -e '/^ *build_all \\$/d' \
+ -e 's/^\#\(!macx\)/\1/' \
+ src/src.pro || die "sed failed"
+
+ sed -i -e "s/\(.*\)lib$/\1$(get_libdir)/" src/pcfile.sh || die "sed failed"
+}
+
+src_configure() {
+ eqmake5 qoauth.pro
+}
+
+src_install() {
+ if use doc; then
+ doxygen "${S}"/Doxyfile || die "failed to generate documentation"
+ HTML_DOCS=( "${S}"/doc/html/. )
+ fi
+
+ INSTALL_ROOT="${D}" default
+}