summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-25 18:16:08 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-25 18:18:14 -0700
commit9922c67637ae0cb82fc45c0d03326817067c0929 (patch)
treed7f129073efe6ad6491195ab38663e9638a8fc36 /dev-libs
parentmedia-libs/libepoxy: Version bump to 1.5.10 (diff)
downloadgentoo-9922c67637ae0cb82fc45c0d03326817067c0929.tar.gz
gentoo-9922c67637ae0cb82fc45c0d03326817067c0929.tar.bz2
gentoo-9922c67637ae0cb82fc45c0d03326817067c0929.zip
dev-libs/libevdev: Version bump to 1.12.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libevdev/Manifest1
-rw-r--r--dev-libs/libevdev/libevdev-1.12.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libevdev/Manifest b/dev-libs/libevdev/Manifest
index c9983ec38cae..488a48547d53 100644
--- a/dev-libs/libevdev/Manifest
+++ b/dev-libs/libevdev/Manifest
@@ -1 +1,2 @@
DIST libevdev-1.12.0.tar.xz 443716 BLAKE2B 1df548cc9bc2472c88308eb2794df7d5636d498631b8873a1957f5cc959097235e64f46f61285a3cbe1abbfe1d968946ae181dfcd8150fecfddf212ed7f4e07e SHA512 6c1c1362d5112cdf3816d1f735c27e625f5463ebf10a83d675cd9364c3fb291ebcb91c051da442f1a36ed28ba7dd99af74546707f61274f7d5715c544a0ed04c
+DIST libevdev-1.12.1.tar.xz 446476 BLAKE2B 3b73c50b5e0bdf6dac001c7e34338ece2ba796af711d8f6f9c2928f93a8f41ee484e067c3cb02878de49d631de87229d4b1a377123e385af5997e11f7c556510 SHA512 eefce287a665e4f89eb2e0437dfefd45ecf8925c7dac35a1bdd46158541f77f2032c6146900a30a01321751d55a9b537bd1d61777cca9cfa02c39a6e31c97be4
diff --git a/dev-libs/libevdev/libevdev-1.12.1.ebuild b/dev-libs/libevdev/libevdev-1.12.1.ebuild
new file mode 100644
index 000000000000..87b1d58afa37
--- /dev/null
+++ b/dev-libs/libevdev/libevdev-1.12.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit meson-multilib python-any-r1
+
+DESCRIPTION="Handler library for evdev events"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig
+"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature doc documentation)
+ $(meson_feature test tests)
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ meson_src_test -t 100
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ local HTML_DOCS=( doc/html/. )
+ einstalldocs
+ fi
+}