summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoralfr <alfr0451@protonmail.com>2023-07-27 07:47:47 +0200
committerSam James <sam@gentoo.org>2023-07-27 07:00:54 +0100
commit0792f716e96caf2e6668fd7d95a01fe9e5213196 (patch)
treee69d500412cab75ccd0f38cdc7b5901094d2bc9a /dev-lisp/asdf
parentprofiles: remove acct-user/logcheck and acc-group/logcheck from package.mask (diff)
downloadgentoo-0792f716e96caf2e6668fd7d95a01fe9e5213196.tar.gz
gentoo-0792f716e96caf2e6668fd7d95a01fe9e5213196.tar.bz2
gentoo-0792f716e96caf2e6668fd7d95a01fe9e5213196.zip
dev-lisp/asdf: fix install for USE=doc
Further, the documentation is always built from the texinfo. Closes: https://bugs.gentoo.org/883439 Signed-off-by: alfr <alfr0451@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-lisp/asdf')
-rw-r--r--dev-lisp/asdf/asdf-3.3.5.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/dev-lisp/asdf/asdf-3.3.5.ebuild b/dev-lisp/asdf/asdf-3.3.5.ebuild
index ec2711fa383a..9acbc8d5209d 100644
--- a/dev-lisp/asdf/asdf-3.3.5.ebuild
+++ b/dev-lisp/asdf/asdf-3.3.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,8 +17,8 @@ RESTRICT="!test? ( test )"
DEPEND="!dev-lisp/cl-${PN}
!<dev-lisp/asdf-2.33-r3
- doc? ( virtual/texi2dvi )
test? ( virtual/commonlisp )"
+BDEPEND="doc? ( sys-apps/texinfo )"
PDEPEND="virtual/commonlisp
~dev-lisp/uiop-${PV}"
@@ -31,15 +31,14 @@ install_docs() {
(
cd doc || die
dodoc *.{html,css,ico,png} ${PN}.pdf
- dodoc -r asdf
- )
+ doinfo ${PN}.info
- if has_version ">=dev-lisp/sbcl-1.4.0" ; then
- (
- cd doc || die
- doinfo ${PN}.info
- )
- fi
+ if has_version -b '<sys-apps/texinfo-7'; then
+ dodoc -r asdf
+ else
+ dodoc -r asdf_html
+ fi
+ )
}
src_compile() {