summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-09-16 16:00:03 +0200
committerUlrich Müller <ulm@gentoo.org>2023-09-16 16:06:33 +0200
commit5ebb70847931586690ca3bc1e34f0b6599b5a1e1 (patch)
tree097c25a81133d504fd566d53bb3ba461b388ae74 /dev-lisp
parentapp-accessibility/at-spi2-core: Version bump to 2.50.0 (diff)
downloadgentoo-5ebb70847931586690ca3bc1e34f0b6599b5a1e1.tar.gz
gentoo-5ebb70847931586690ca3bc1e34f0b6599b5a1e1.tar.bz2
gentoo-5ebb70847931586690ca3bc1e34f0b6599b5a1e1.zip
dev-lisp/clisp: Specify LICENSE more precisely, update EAPI to 8
Closes: https://bugs.gentoo.org/880171 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/clisp-2.49.92-r1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/dev-lisp/clisp/clisp-2.49.92-r1.ebuild b/dev-lisp/clisp/clisp-2.49.92-r1.ebuild
index b27879b84797..dc22d9b9e28e 100644
--- a/dev-lisp/clisp/clisp-2.49.92-r1.ebuild
+++ b/dev-lisp/clisp/clisp-2.49.92-r1.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit flag-o-matic multilib toolchain-funcs xdg-utils
+inherit flag-o-matic xdg-utils
DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
HOMEPAGE="https://clisp.sourceforge.io/"
SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="2/8"
KEYWORDS="~alpha amd64 ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
IUSE="hyperspec X berkdb dbus fastcgi gdbm gtk +pcre postgres +readline svm threads +unicode +zlib"
@@ -131,11 +131,12 @@ src_compile() {
}
src_install() {
- pushd "${BUILDDIR}"
+ pushd "${BUILDDIR}" || die
make DESTDIR="${D}" prefix="${EPREFIX}"/usr install-bin || die "Installation failed"
doman clisp.1
dodoc ../SUMMARY README* ../src/NEWS ../unix/MAGIC.add ../ANNOUNCE
- popd
- dohtml doc/impnotes.{css,html} doc/regexp.html doc/clisp.png
+ popd || die
dodoc doc/{CLOS-guide,LISP-tutorial}.txt
+ docinto html
+ dodoc doc/impnotes.{css,html} doc/regexp.html doc/clisp.png
}