summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Payno <vpayno+gentoo@gmail.com>2020-03-02 13:16:45 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-03-15 17:11:56 -0700
commitb6f22240d2351b53a3b5aa9dba6a21bbb117d47e (patch)
tree184d93b0b70cd248f0395168564af9eb990b4755 /dev-lua/penlight/penlight-1.7.0.ebuild
parentdev-lua/penlight: version bump to 1.5.4 (diff)
downloadgentoo-b6f22240d2351b53a3b5aa9dba6a21bbb117d47e.tar.gz
gentoo-b6f22240d2351b53a3b5aa9dba6a21bbb117d47e.tar.bz2
gentoo-b6f22240d2351b53a3b5aa9dba6a21bbb117d47e.zip
dev-lua/penlight: version bump to 1.7.0
Closes: https://github.com/gentoo/gentoo/pull/14440 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lua/penlight/penlight-1.7.0.ebuild')
-rw-r--r--dev-lua/penlight/penlight-1.7.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-lua/penlight/penlight-1.7.0.ebuild b/dev-lua/penlight/penlight-1.7.0.ebuild
new file mode 100644
index 000000000000..1036bea9323e
--- /dev/null
+++ b/dev-lua/penlight/penlight-1.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua utility libraries loosely based on the Python standard libraries"
+HOMEPAGE="https://github.com/Tieske/Penlight",
+SRC_URI="https://github.com/Tieske/Penlight/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=dev-lang/lua-5.1:=
+ dev-lua/luafilesystem"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN//penlight/Penlight}-${PV}"
+
+src_install() {
+ local -a DOCS=( README.md CHANGELOG.md LICENSE.md CONTRIBUTING.md )
+ einstalldocs
+
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+ doins -r lua/pl
+}