summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-28 16:39:07 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-28 17:16:35 +0100
commitc12f16cadf77edcecf82bc944a2a15afc1ae2757 (patch)
treea76f52ab9c864be22aad2c19e3a7b76b4c8d9e61 /dev-lua/say
parentnet-im/kadu: Remove last-rited package (diff)
downloadgentoo-c12f16cadf77edcecf82bc944a2a15afc1ae2757.tar.gz
gentoo-c12f16cadf77edcecf82bc944a2a15afc1ae2757.tar.bz2
gentoo-c12f16cadf77edcecf82bc944a2a15afc1ae2757.zip
dev-lua/say: migrate to lua eclass
Also adding tests. Bug: https://bugs.gentoo.org/628758 Closes: https://bugs.gentoo.org/752945 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/say')
-rw-r--r--dev-lua/say/metadata.xml4
-rw-r--r--dev-lua/say/say-1.3_p1-r100.ebuild48
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-lua/say/metadata.xml b/dev-lua/say/metadata.xml
index 91d1cb37065b..dba514960b1e 100644
--- a/dev-lua/say/metadata.xml
+++ b/dev-lua/say/metadata.xml
@@ -5,6 +5,10 @@
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
<upstream>
<remote-id type="github">Olivine-Labs/say</remote-id>
</upstream>
diff --git a/dev-lua/say/say-1.3_p1-r100.ebuild b/dev-lua/say/say-1.3_p1-r100.ebuild
new file mode 100644
index 000000000000..ab75e614cb95
--- /dev/null
+++ b/dev-lua/say/say-1.3_p1-r100.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+MY_PV="${PV/_p/-}"
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="Lua String Hashing/Indexing Library"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+RDEPEND="${LUA_DEPS}"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( >=dev-lua/busted-2.0.0-r100 )
+ ${RDEPEND}
+"
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto $(lua_get_lmod_dir)/say
+ doins src/init.lua
+
+ einstalldocs
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+}