summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2024-06-22 21:41:07 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 22:00:10 +0200
commit047decbb9fc379b90993d97a56e4b7487cc3551f (patch)
tree11a768f7b2aca10fb63ce2b5c2c4ee2aea9b4405 /dev-lua
parentdev-lua/lualdap: drop 1.3.1 (diff)
downloadgentoo-047decbb9fc379b90993d97a56e4b7487cc3551f.tar.gz
gentoo-047decbb9fc379b90993d97a56e4b7487cc3551f.tar.bz2
gentoo-047decbb9fc379b90993d97a56e4b7487cc3551f.zip
dev-lua/luarocks: drop 3.11.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luarocks/Manifest1
-rw-r--r--dev-lua/luarocks/luarocks-3.11.0.ebuild86
2 files changed, 0 insertions, 87 deletions
diff --git a/dev-lua/luarocks/Manifest b/dev-lua/luarocks/Manifest
index 25e001e036c0..166f4eb82d99 100644
--- a/dev-lua/luarocks/Manifest
+++ b/dev-lua/luarocks/Manifest
@@ -1,2 +1 @@
-DIST luarocks-3.11.0.tar.gz 277031 BLAKE2B eadef03badc9b4f0784e67f08f4fbfb4032840e6f7378e20dd2460da6324bba9c6f0210803b42a5e7465a44f0a3cf706c555ba64f622ce3884ac0b49f42304ad SHA512 bec918e98209e5ff5c498c4454b8c8182ecfeb0786cb4cd241d59149f33560e981ff2db8d49785823ccf31643366de15b5f2599c6eef0951d17ba66436b79644
DIST luarocks-3.11.1.tar.gz 277760 BLAKE2B 9470b0cd01329e223769b53a5aea743916c2ffedd6171a0b06e105131e2475ec4919fc1e6347162d1049ae5b2d9b32bea705e35577e58edaa29dddb910d343e7 SHA512 1e214fd41711f62fda122d73441165a2d0ffe7ed29d3d3d7690b9a1a272c03e269fc39e0c2d35dddaa64fad411b87754da4e7b8236af562fde837e9e6626fbad
diff --git a/dev-lua/luarocks/luarocks-3.11.0.ebuild b/dev-lua/luarocks/luarocks-3.11.0.ebuild
deleted file mode 100644
index 780e6d75e53f..000000000000
--- a/dev-lua/luarocks/luarocks-3.11.0.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua-single
-
-DESCRIPTION="A package manager for the Lua programming language"
-HOMEPAGE="https://luarocks.org"
-SRC_URI="https://luarocks.org/releases/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="test"
-
-RDEPEND="${LUA_DEPS}"
-
-DEPEND="
- net-misc/curl
- dev-libs/openssl:0
- ${RDEPEND}
-"
-
-BDEPEND="
- virtual/pkgconfig
- test? (
- $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]')
- $(lua_gen_cond_dep 'dev-lua/busted-htest[${LUA_USEDEP}]')
- ${RDEPEND}
- )
-"
-
-src_prepare() {
- default
-
- # If 'dev-lang/lua' is a new, fresh installation, no 'LUA_LIBDIR' exists,
- # as no compiled modules are installed on a new, fresh installation,
- # so this check must be disabled, otherwise 'configure' will fail.
- sed -e '/LUA_LIBDIR is not a valid directory/d' -i configure || die
-}
-
-src_configure() {
- local myeconfargs=(
- "--prefix=${EPREFIX}/usr"
- "--rocks-tree=$(lua_get_lmod_dir)"
- "--with-lua-include=$(lua_get_include_dir)"
- "--with-lua-interpreter=${ELUA}"
- "--with-lua-lib=$(lua_get_cmod_dir)"
- )
-
- # Since the configure script is handcrafted,
- # and yells at unknown options, do not use 'econf'.
- ./configure "${myeconfargs[@]}" || die
-}
-
-src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_install() {
- default
-
- { find "${D}" -type f -exec sed -i -e "s:${D}::g" {} \;; } || die
-}
-
-pkg_postinst() {
- local lua_abi_ver
- if use lua_single_target_luajit; then
- lua_abi_ver="5.1"
- else
- lua_abi_ver=${ELUA#lua}
- fi
- elog
- elog "To manage rocks for a Lua version other than the current ${CATEGORY}/${PN} default (${lua_abi_ver})"
- elog "you can use the command-line option --lua-version, e.g."
- elog
- elog " luarocks --lua-version 5.3 install luasocket"
- elog
- elog "(use 5.1 for luajit). Note that the relevant Lua version must already be present in the system."
- elog
-}