summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-06 15:56:10 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-06 15:56:16 +0100
commit350bbda4fc962573dfb55f23a8a2a6ed0f5d1f14 (patch)
tree4db1f0bd5e82575137724a1e56105049cddf846e /dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.3.ebuild
parentdev-ml/ocaml-re: bump to 1.5.0 (diff)
downloadgentoo-350bbda4fc962573dfb55f23a8a2a6ed0f5d1f14.tar.gz
gentoo-350bbda4fc962573dfb55f23a8a2a6ed0f5d1f14.tar.bz2
gentoo-350bbda4fc962573dfb55f23a8a2a6ed0f5d1f14.zip
dev-ml/ocaml-sqlite3: bump to 4.0.3
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.3.ebuild')
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.3.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.3.ebuild
new file mode 100644
index 000000000000..d10376724c86
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_PN="sqlite3-ocaml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases"
+HOMEPAGE="http://mmottl.github.io/sqlite3-ocaml/"
+SRC_URI="https://github.com/mmottl/sqlite3-ocaml/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-db/sqlite-3.3.3
+ >=dev-ml/findlib-1.3.2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" "TODO.md" )